#635 Devices are listed twice

1.1
closed-fixed
PCMan
libfm (303)
5
2012-11-22
2012-10-19
Don
No

Hello,

Devices are listed twice, if PCManFM is not started as daemon (pcmanfm -d)
I'm using PCManFM 1.0.2~alpha1, but this bug appears since the version 1.0.1.

Discussion

  • Sérgio Cipolla

    Sérgio Cipolla - 2012-10-20

    This doesn't happen here. It looks to me as a bug in some other package in your distribution.
    Have you checked in other file managers if it shows twice too?

     
  • Don

    Don - 2012-10-20

    What packages can cause this bug ?
    Yes, I've tried with Nautilus and it's OK.

    I also tested on a Lubuntu Live CD (killall pcmanfm && pcmanfm), the bug is here too.
    PCManFM v1.0 worked fine.

     
  • Lonely Stranger

    Lonely Stranger - 2012-10-20
    • labels: 2616493 --> libfm
     
  • Lonely Stranger

    Lonely Stranger - 2012-10-20

    lelapin01@: This sometimes happens to me too. I still ignored it thinking it's my local configuration problem (which is not very common). As soon it happens to others too, I'll inspect that closer.
    Thank you very much!

     
  • Don

    Don - 2012-10-20

    @lstranger: OK.
    I tested with Thunar and it is also affected by this bug.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-10-20

    Fedora 18 Xfce live-CD alpha had this bug due to udisks. It was fixed in udisks 2.0 AFAIK

    I use F17 with udisks 1.94 and this doesn't happen.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-10-20

    udisks 1.99 may show this bug (if it's the same that makes file manager and xfdesktop show partitions twice).

     
  • Lonely Stranger

    Lonely Stranger - 2012-10-20

    I have udisks 1.0.4 (it's Ubuntu Oneiric) and the bug is present. In Precise with udisks 1.0.4 (the same version) no such behavior experienced (with exactly the same libfm/pcmanfm binaries). But I believe udisks isn't used on any of these two computers but GVFS instead and those distros have different GVFS versions - 1.10 and 1.12.

    And I found no difference in behavior if pcmanfm started with -d or not. Also there is no difference in 'Places' sidebar related to volumes/mounts handling between libfm versions 1.0 and 1.0.2 so I suspect you've upgraded gvfs at the time of migration 1.0 -> 1.0.1.

     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-10-20

    Just to be more clear it may be called udisks2 (when the legacy udisks is still in the repo).

     
  • Don

    Don - 2012-10-21

    Yes, the bug seems to come from GVFS (I have v1.14.0), I removed the package and it's OK now.
    @shamuayka: I already have udisks v2.0.0.

    By the way, I never seen the mount point for the root partition listed in the sidebar, is there a reason for this?

     
  • Don

    Don - 2012-10-21
    • status: open --> closed-invalid
     
  • PCMan

    PCMan - 2012-11-22
    • assigned_to: nobody --> pcmanx
     
  • PCMan

    PCMan - 2012-11-22

    I did some additional fixes in the latest git head.
    The problem is caused by new gvfs, but can be avoided by adding some more checks.

     
  • PCMan

    PCMan - 2012-11-22
    • status: closed-invalid --> closed-fixed
     
  • Sérgio Cipolla

    Sérgio Cipolla - 2012-11-22

    Just to point out that gvfs 1.14.2 with the fix has been released for some time so folks should rather bother their distros to update it.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks