#538 no file change monitoring

1.0
closed-fixed
PCMan
pcmanfm (129)
6
2012-05-22
2012-05-18
No

I am using pcmanfm-0.9.10 and libfm-0.1.17 on NetBSD.

I don't get any changes to the desktop nor in the filemanager window unless I manually select Reload from its menu. If I use same pcmanfm process as --desktop then it will update my desktop too.

Maybe it is related to:
(pcmanfm:3589): Gtk-WARNING **: Unable to find default local directory monitor type

I don't know. I recall the code used to use gamin or fam. But I don't see that anymore. Maybe it is related to ./src/base/fm-monitor.c

Discussion

  • PCMan

    PCMan - 2012-05-21
    • status: open --> closed-invalid
     
  • PCMan

    PCMan - 2012-05-21

    This is either a configuration problem or a bug in glib.
    That error message belongs to glib/gio.
    See glocaldirectorymonitor.c in glib source code.

    <quote>
    monitor = NULL;
    if (type != G_TYPE_INVALID)
    monitor = G_FILE_MONITOR (g_object_new (type, "dirname", dirname, "flags", flags, NULL));
    else
    g_set_error_literal (error, G_IO_ERROR, G_IO_ERROR_FAILED,
    _("Unable to find default local directory monitor type"));
    </qoute>

    Glib/gio returns this error when a working implementation for local file monitoring is not available or cannot be initiated. I believed that your FAM or gamin is not correctly installed. I'm sure that It's not a bug of pcmanfm/libfm.
    If the configuration is correct and FAM is working well, then please bug report to glib developers and ask them to test glib/gio file monitor on NetBSD.

     
  • Jeremy C. Reed

    Jeremy C. Reed - 2012-05-21

    Thank for the further research.

    I installed
    gio-fam-2.32.3 FAM backend for GIO, the glib VFS API

    And I started rpcbind (portmapper), famd, and restarted pcmanfm. And it works.

    Can you please consider putting a note about this in your top-level README file? Then this ticket may be closed.

    Also on a related note, see work/pcmanfm-0.9.10/po/sv.po
    work/pcmanfm-0.9.10/po/he.po
    work/pcmanfm-0.9.10/po/gl.po
    work/pcmanfm-0.9.10/po/sk.po
    all mention FAM or Gamin (maybe old docs?)

     
  • Jeremy C. Reed

    Jeremy C. Reed - 2012-05-21
    • status: closed-invalid --> open-invalid
     
  • PCMan

    PCMan - 2012-05-22
    • priority: 5 --> 6
    • milestone: --> 1.0
     
  • PCMan

    PCMan - 2012-05-22
    • assigned_to: nobody --> pcmanx
     
  • PCMan

    PCMan - 2012-05-22

    README updated.
    Thanks.

     
  • PCMan

    PCMan - 2012-05-22
    • status: open-invalid --> closed-fixed
     


Anonymous

Cancel  Add attachments