#527 HTML5 DnD upload from PCManFM to Firefox or Chromium fail

1.1
closed-fixed
libfm (303)
4
2012-09-22
2012-03-12
No

When using drag-and-drop HTML5 uploading, attempts to drag files from Konqueror or Nautilus to Firefox or Chrome/Chromium work perfectly, but attempts to drag files from PCManFM either only work sometimes (Chrome) or open the file as if the site hadn't requested to handle drag-and-drop (Firefox).

Version: PCManFM 0.9.9 as distributed with Lubuntu 11.10 (Oneiric Ocelot).

Steps to reproduce:
1. Create some trivial, pointless file. (Or use the attached one)
2. Open Firefox or Chrome and navigate to http://www.mediafire.com/ (no account required)
3. Open PCManFM
4. Drag the trivial, pointless file onto the folder graphic in the browser.
5. Watch as the browser displays or offers a download of the file (Firefox) or sometimes ignores the drag-and-drop (Chrome).
6. Repeat with Konqueror or Nautilus and watch as the MediaFire upload manager kicks into action every time.

Discussion

  • Stephan Sokolow

    Stephan Sokolow - 2012-03-12

    The file I used for my drag-and-drop testing

     
  • PCMan

    PCMan - 2012-05-08
    • priority: 5 --> 4
    • assigned_to: nobody --> pcmanx
    • milestone: --> 2297538
     
  • Lonely Stranger

    Lonely Stranger - 2012-07-05

    Chrome browser opens your file when I drop it onto http://www.mediafire.com/ from Nautilus the same way as if I drop it from Pcmanfm.

     
  • Stephan Sokolow

    Stephan Sokolow - 2012-07-06

    I forgot to update this bug. Since I posted this report, MediaFire reworked their UI so you now need to create an account and sign-in to get a drag-and-drop uploading UI.

    Use the drag-and-drop similarity search feature in Google Image search instead.

    First, make sure Google Images shows a drop target when you hover over it without releasing. If it does, then your dragging and dropping properly and you don't have something like NoScript interfering.

    Second, try actually dropping the dragged image. In my tests with Firefox, drags from PCManFM had no effect (The drop target just re-hid when I released) while drags from Konqueror worked flawlessly.

    (I reinstalled recently and Nautilus isn't currently installed, so I didn't test with it.)

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-14

    It works for me in Chrome with the file supplied by you - dropping it onto the Google Images prompt from pcmanfm 1.0rc1 got it to upload and Google complained it was not an image. The same behavior have all of: Thunar, Nautilus, and Dolphin. Either it's fixed or it requires some different diagnostics. Unfortunately I could not test it with Firefox since I have only version 4.0 here as more recent ones freeze sometimes and with 4.0 I could not get it uploaded from any of FM, sorry.

     
  • Stephan Sokolow

    Stephan Sokolow - 2012-07-15

    Hmm. I'm still on 0.9.10. What's the simplest, least time-consuming way to set up 1.0rc1 for testing on a Lubuntu box?

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-15

    If you want fast way for *ubuntu then you can use my PPA:
    sudo add-apt-repository ppa:andrej-rep/ppa
    It's still 0.1.99-0+git120708 name there but it was built right before renaming into 1.0rc1 so it's the same one.

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-15

    It's libfm 0.1.99-0+git120708, pcmanfm is 0.9.10-0+git120708 there. Both are equal to 1.0rc1.

     
  • Stephan Sokolow

    Stephan Sokolow - 2012-07-15

    Well, drag-and-drop from that version of PCManFM works into Chrome, but not into my Aurora-channel copy of Firefox. DnD from Konqueror works into both. As before, I don't currently have Nautilus installed to test with but it worked into both last I tried.

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-16

    I've found out it works with Firefox 10 from Dolphin and Nautilus but doesn't work from Thunar and Pcmanfm. The issue needs more deep investigation. Thank you for testing!

     
  • Lonely Stranger

    Lonely Stranger - 2012-07-16
    • milestone: 2297538 --> 2334032
     
  • Lonely Stranger

    Lonely Stranger - 2012-07-18
    • labels: 2616493 --> libfm
     
  • Lonely Stranger

    Lonely Stranger - 2012-09-22

    This is not pcmanfm bug as Firefox accepted the URI but ignored it. There is a ticket in mozilla bug tracker:

    https://bugzilla.mozilla.org/show_bug.cgi?id=609284

    But anyway I've fixed it somehow, fix is in Git repository already. Check it out when it's possible for you and if the bug still exists then reopen the report, please.
    Thank you very much.

     
  • Lonely Stranger

    Lonely Stranger - 2012-09-22
    • milestone: 2334032 --> 1.1
    • assigned_to: pcmanx --> lstranger
    • status: open --> closed-fixed
     
  • Stephan Sokolow

    Stephan Sokolow - 2012-09-22

    *nod* I discovered that Firefox bug about a month ago but forgot to mention it here. It seems Firefox's support for X11 drag-and-drop is very picky about what kinds of representations it'll accept for a dropped file.

     
  • Stephan Sokolow

    Stephan Sokolow - 2012-09-22
    • status: closed-fixed --> open-fixed
     
  • Lonely Stranger

    Lonely Stranger - 2012-09-22

    I hope you opened the ticket just accidentally because I think I've fixed it completely. :)

     
  • Stephan Sokolow

    Stephan Sokolow - 2012-09-22

    I did. I just posted a comment and this archaic, odd bug tracker's default behaviour did the rest. If I understand the UI correctly, this comment should re-close it.

     
  • Stephan Sokolow

    Stephan Sokolow - 2012-09-22
    • status: open-fixed --> closed-fixed
     


Anonymous

Cancel  Add attachments