#468 segfault when selecting area while directory is loading

1.1
closed-fixed
libfm (303)
7
2012-09-21
2011-08-12
Anonymous
No

When opening a directory and selecting an empty area, libfm segfaults, and then pcmanfm crashes
When running in gdb, pcmanfm is still running after libfm crashed, but it doesn't respond and also doesn't update window contents.
Backtrace attached.

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-08-12

    backtrace

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-08-12

    I've used pcmanfm version 0.9.8-6 and libfm 0.1.14-5 from archlinux repo.

     
  • PCMan

    PCMan - 2011-11-18

    I'll try to fix this before 1.0 release, but there is no guarantee since till now I'm not able to reproduce the bug here.

     
  • PCMan

    PCMan - 2011-11-18
    • assigned_to: nobody --> pcmanx
    • milestone: --> 557433
    • labels: --> libfm
     
  • PCMan

    PCMan - 2012-05-08
    • status: open --> closed-out-of-date
     
  • PCMan

    PCMan - 2012-05-08

    The backtrace included did not provide diagnostic information.
    I repeated your test case for many times and there is no crash.
    I think it has been fixed in git.
    Please test the latest source code in git repo.
    If the bug still exists, open this bug again.
    Thanks.

     
  • Márton Szász

    Márton Szász - 2012-09-17

    Sorry for not giving attention to this report.
    I can still reproduce the bug in 1.0.
    I select an empty area while the directory is being loaded and when it would finish loading, instead of showing contents, it segfaults.
    Tried strace on it, and this showed up on the end as many times as many items I would have selected:
    recv(3, 0x9678ba0, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)

     
  • Márton Szász

    Márton Szász - 2012-09-17

    I've tried with git version and it's still there.
    Steps to reproduce:
    - Open pcmanfm
    - Navigate to a huge directory (in terms of number of files and directories) like /usr/bin
    - Select an area while it's loading (you're late if you select that area when content are loaded but still not drawn, this lasts for maybe 0.1s for me)
    The program exits with segmentation fault.
    This may not be a problem however, because no one wants to select anything while no content are loaded, but it's a bug.

     
  • Lonely Stranger

    Lonely Stranger - 2012-09-17
    • milestone: 557433 --> 1.1
    • priority: 5 --> 7
    • assigned_to: pcmanx --> lstranger
    • status: closed-out-of-date --> open
     
  • Lonely Stranger

    Lonely Stranger - 2012-09-17

    Thank you very much for detailed description. It segfaults in exo_icon_view_update_rubberband_selection function. When it's folder with 50000 files then that takes a little more than 0.1s so can be caught more easily.

     
  • Lonely Stranger

    Lonely Stranger - 2012-09-17
    • status: open --> open-accepted
     
  • Lonely Stranger

    Lonely Stranger - 2012-09-21

    We hope this issue is completely fixed in the Git repository recently.
    Check it out when it's possible for you and if the bug still exists then reopen the report, please.
    Thank you very much.

     
  • Lonely Stranger

    Lonely Stranger - 2012-09-21
    • status: open-accepted --> closed-fixed
     
  • Márton Szász

    Márton Szász - 2012-09-26

    I confirm that it's fixed in git. Thanks!

     


Anonymous

Cancel  Add attachments