Error during mapping stage

crd1859
2014-04-15
2014-09-22
  • crd1859

    crd1859 - 2014-04-15

    I receive the following error during the mapping phase:

    2014-04-15 05:11:55,397 [INFO] Extracting tails
    Traceback (most recent call last):
    File "/home/peter/bioinformatics/pbjelly//bin/m4pie.py", line 203, in <module>
    run(sys.argv[1:])
    File "/home/peter/bioinformatics/pbjelly//bin/m4pie.py", line 182, in run
    r, t, m = extractTails(aligns, reads, outFq=tailfastq, minLength=args.minTail)
    File "/home/peter/bioinformatics/pbjelly//bin/m4pie.py", line 59, in extractTails
    seq = reads[read.qname][-eTail:]
    eyError: 'm130830_173431_42164_c100578522550000001823093601191440_s1_p0/58/0_1558'

    Any advice would be appreciated.

    Peter

     
  • Luk

    Luk - 2014-05-02

    Hello Peter!

    I had the same error. Go check if the headers in the fastq contain whitespace and if so, remove it. That solved the problem for me.

    Best

     
  • Fish

    Fish - 2014-09-22

    Hello Peter,
    Go theck the header of your PacBio reads,whether the header contain the other information like "RQ=0.888". then you shoule delete all informations of header except the reads name. In orther word ,the fastq's header must contain and only contain the reads name.

    Best

     
    Last edit: Fish 2014-09-25

Log in to post a comment.