[WARNING] No gaps to be assembled were found in /usr/local/bin/Jelly_14.1.14/docs/jellyExample/assembly! Have you run 'extraction' yet?

Biomonika
2014-01-21
2014-01-22
  • Biomonika

    Biomonika - 2014-01-21

    I have just started using PBJelly and went according to the manual: I have first created fake qual scores fore lambda.fasta, modified Protocol.xml and then run following commands:

    Jelly.py setup Protocol.xml
    Jelly.py mapping Protocol.xml
    Jelly.py support Protocol.xml
    Jelly.py extraction Protocol.xml
    Jelly.py assembly Protocol.xml

    This is output of last command:

    2014-01-21 14:47:49,930 [INFO] Running /usr/local/bin/Jelly_14.1.14/bin/Jelly.py assembly Protocol.xml
    2014-01-21 14:47:49,931 [INFO] Executing Stage: assembly
    2014-01-21 14:47:49,932 [WARNING] No gaps to be assembled were found in /usr/local/bin/Jelly_14.1.14/docs/jellyExample/assembly! Have you run 'extraction' yet?

    I have been trying to fix the problem and found out following

    filtered_subreads.fastq.out under support folder is empty and filtered_subreads.fastq.err looks like this:

    2014-01-21 14:38:05,768 [INFO] Running /usr/local/bin/Jelly_14.1.14/bin/Support.py /usr/local/bin/Jelly_14.1.14/docs/jellyExample/mapping/filtered_subreads.fastq.m4 /usr/local/bin/Jelly_14.1.14/docs/jellyExample/data/reference/lambda.gapInfo.bed /usr/local/bin/Jelly_14.1.14/docs/jellyExample/support/filtered_subreads.fastq.gml
    2014-01-21 14:38:05,769 [INFO] Building Helper Objects
    2014-01-21 14:38:05,769 [INFO] Connecting Alignments
    2014-01-21 14:38:05,894 [INFO] Classifying Alignments' Support
    2014-01-21 14:38:05,934 [WARNING] Read ['m130725_000747_00121_c100518582550000001823079209281362_s1_p0/15956/701_2749'] self-extends Node ref0000002e5 Possible Evidence of Tandem Repeat on Singleton
    2014-01-21 14:38:05,955 [WARNING] Read ['m130724_230321_00121_c100518582550000001823079209281361_s1_p0/57008/1515_3578'] self-extends Node ref0000002e3 Possible Evidence of Tandem Repeat on Singleton
    2014-01-21 14:38:05,962 [INFO] Saving Support Graph
    2014-01-21 14:38:05,963 [INFO] Finished

    In assembly folder, extraction.out is again empty, nevertheless extraction.err has following content:

    2014-01-21 14:38:13,669 [INFO] Running /usr/local/bin/Jelly_14.1.14/bin/Extraction.py /usr/local/bin/Jelly_14.1.14/docs/jellyExample/Protocol.xml
    2014-01-21 14:38:13,670 [INFO] Opening GML Files
    2014-01-21 14:38:13,705 [INFO] Loading Reference Sequence
    2014-01-21 14:38:13,765 [INFO] Extracting Reads
    2014-01-21 14:38:13,765 [INFO] Parsing /usr/local/bin/Jelly_14.1.14/docs/jellyExample/data/reads/filtered_subreads.fastq
    2014-01-21 14:38:13,786 [INFO] Loaded 500 Reads
    2014-01-21 14:38:13,788 [INFO] Parsed 111 Reads
    Traceback (most recent call last):
    File "/usr/local/bin/Jelly_14.1.14/bin/Extraction.py", line 315, in <module>
    me.run()
    File "/usr/local/bin/Jelly_14.1.14/bin/Extraction.py", line 288, in run
    self.extractReads()
    File "/usr/local/bin/Jelly_14.1.14/bin/Extraction.py", line 196, in extractReads
    self.flushQueue(outputQueue)
    File "/usr/local/bin/Jelly_14.1.14/bin/Extraction.py", line 211, in flushQueue
    outFile = self.openGapOut(gapName)
    File "/usr/local/bin/Jelly_14.1.14/bin/Extraction.py", line 237, in openGapOut
    sequence = self.reference[flankName[:10]]
    KeyError: '6'

    I do believe that mapping step worked OK since I successfully generated filtered_subreads.fastq.m4 file.

    Will be very thankful for help.

     
  • Adam English

    Adam English - 2014-01-21

    Can you ensure that you have networkx v1.1 installed?

     
  • Biomonika

    Biomonika - 2014-01-22

    Thank you very much, this time it worked flawlessly. Here are the commands in case anybody is interested:

    pip uninstall networkx
    pip install http://networkx.lanl.gov/download/networkx/networkx-1.1.tar.gz

     
    Last edit: Biomonika 2014-01-22

Log in to post a comment.