Cant run Pastebot

Help
Pebcak
2004-10-29
2013-03-07
  • Pebcak

    Pebcak - 2004-10-29

    make install-cpan and make install run with no problems, I edit the conf file but when I go to run pastebot I get the following:

    While loading library [Server::Web]
    /usr/local/bin/pastebot Error while loading Server::Web: mkdir pastestore failed No such file or directory at Util/Data.pm line 268.
    Compilation failed in require at Server/Web.pm line 20.
    BEGIN failed--compilation aborted at Server/Web.pm line 20.
    Compilation failed in require at (eval 101) line 1.
    BEGIN failed--compilation aborted at (eval 101) line 1.

    Please make sure that the following libraries
    have been installed:
    Perl::Tidy POE Server::Web Client::IRC

    They are definatly installed though as when iI make install-cpan I get:
    === Installing and/or updating CPAN modules...
    CPAN: Storable loaded ok
    Going to read /root/.cpan/Metadata
      Database was generated on Thu, 28 Oct 2004 03:11:19 GMT
    HTTP::Request is up to date.
    HTTP::Response is up to date.
    HTTP::Status is up to date.
    Perl::Tidy is up to date.
    POE is up to date.
    POE::Component::IRC is up to date.
    Storable is up to date.
    Text::Template is up to date.
    Time::HiRes is up to date.
    URI is up to date.

    Anyone have an idea what I missed and what to do to get the bot up and running?

    Thanks

     
    • belea

      belea - 2005-03-15

      you need to run "make install" after make install-cpan

       

Log in to post a comment.