PS 3.19 Unable to open after power down

Don Walker
  • Don Walker

    Don Walker - 2009-10-03

    I had to power down my PC with the power button while PS 3.19 was open. When I
    restarted the timestamp on the database was about the time of the power down
    and I wasn't able to open it. Does something happen on power-down that
    corrupts the db? Even worse, I then tried to open the .ibak file, which was a
    few days older, and it wouldn't open either. Is this a bug? I first tried a
    direct open and then a "Restore from backup". I've got an older copy
    of the database from another PC so I may only be missing a few changes - it
    would be nice if I could get them back. Is there anything special I need to do
    to open the .ibak file?

  • Rony Shapiro

    Rony Shapiro - 2009-10-03


    The backup file is in the same format as the main database, so you should be
    able to open it in the same way, e.g., via File->Open.

    The main file may have been corrupted as PasswordSafe tried to save data
    during the powerdown. This doesn't explain the problem with the .ibak file,
    though. Could be the disk's flakey?


  • Don Walker

    Don Walker - 2009-10-03

    I doubt that the disk is flakey. I use NTFS and ran chkdsk after the problem
    happened. It didn't find anything. I've never had problems with previous power
    downs while running. In this case the power down also partially corrupted my
    FIrefox profile (Firefox was also running at the time). I didn't see any
    unusual messages in the event log.

  • DrK

    DrK - 2009-10-04

    Given that you say your Firefox running and its profile was damaged too
    suggests that your disk did have a problem and it isn't surprising that your
    PasswordSafe database may have been damaged too.

    However, as Rony suggests, opening the 'ibak' file should give a good version
    without the very last changes.

    When PWS saves a database, it renames the original to the have the 'ibak'
    extension and then writes a new file with the 'psafe3' extension. So the
    'ibak' version should be good. Just open it as normal.


  • Don Walker

    Don Walker - 2009-10-04

    After reading your arguments I have to agree that the power down appears to
    have damaged files connected to apps that were open at the time of the
    shutdown. At this point I have no indication from chkdsk or event log review
    of what happened so for now I'll treat it as "one of those things".

    I still can't open the .ibak file. All I can suggest is that we monitor other
    postings to see if anyone reports a similar problem.

    Thanks for your comments and efforts.

  • Linda Lawrie

    Linda Lawrie - 2009-10-15

    I am having numerous problems with V3.19. Including one this morning where
    possibly I had to power down while PasswordSafe was open. Both regular and
    backup were corrupted.

  • gonzague pichelin


    I have the same problem.. non of the file can be oppened,

    it is behaving as I would have changed my password but I didn't, and no, it
    osn't one of those case where you think you used this password and it was
    another one....

  • gonzague pichelin

    sorry for the typos

  • niftylass

    niftylass - 2009-11-24

    Piling on... I encountered the same issue.

  • Anonymous - 2009-11-27

    I don't believe my problem was because I powered down while passwordsafe was
    open. It has happened on 2 different computers. I've recreated the database 3
    times and it happens everytime. I like the program, and would like to find a
    way to use it.

  • DrK

    DrK - 2009-11-27

    OK - on the assumption that this is a Bug, I have opened a Bug Report
    (2904859: PS 3.19 Unable to open database). Please use this to add further
    information to help us track this down (From main page->

    Now we do need a lot more information (sorry):

    1. What version of Windows are you
      using (e.g. 2000, XP, Vista, 7) and

    is it the 32-bit or 64-bit edition?

    1. What version of Windows are you using (e.g. English, German, French etc.)?
    2. What is your locale (e.g. US English, UK English, German etc.) and
      type of keyboard (i.e. may be using US English version of Windows with a
      German keyboard)?

    3. How did you install PasswordSafe (e.g. using zip file, exe file or

    4. When creating the database, did you use the real keyboard to enter
      the passphrase or PasswordSafe's Virtual Keyboard facility? If the

    latter, which virtual keyboard(s)?

    1. Have you tried with a previous version of PasswordSafe? If so,
      which version (e.g. 3.18) and did it work OK?

    2. Was the database on a local disk or on a network?

    3. Please describe everything that you did to create the database (for example: "did you create it, add a record, save it, close it and then re-open it without ending PasswordSafe" or "did you create it, add a record, save it, close it, close PasswordSafe" and then later "restart PasswordSafe and try to open the database"?).
    4. Please provide anything else that you may think will help us.

    Please would you also upload to the Bug Report (there is a facility to 'Add a
    file' near the bottom of the Bug Report) the following:

    1. A TEST (i.e. that has no sensitive information within it) database that you can't open (and tell us the passphrase!)?
    2. The configuration file (pwsafe.cfg normally in the PasswordSafe installation directory unless you have overridden the location). Again, please change any information you may feel is sensitive. Do NOT remove the information but change it with similar characters to make it insensitive.

    Many thanks


  • Rony Shapiro

    Rony Shapiro - 2009-11-27


    Just to second David's request for posting more information to help us track
    this down to the bug report form.

    The forthcoming release has some changes which should make PasswordSafe a bit
    more robust in this respect, but without the ability to reproduce this on our
    machines, we can't be certain of a fix.



  • needhelp22

    needhelp22 - 2009-11-28

    I have the same problem. My Database files .ibak and .psafe3 are broken.
    Accept not my correct password. I have many passwords in this file (14kb). I
    am very very pissed

    please help

  • gonzague pichelin

    I found an olod backup of my files..;

  • Rob Weemhoff

    Rob Weemhoff - 2009-12-12

    I have also this problem, and I am willing to share the database in order to
    resolve the problem.

  • Rob Weemhoff

    Rob Weemhoff - 2009-12-14

    Please send your email address (and PGP key) to

  • Xa Dream

    Xa Dream - 2009-12-14

    Hi Rony,

    I just had the issue which I could not open the database file with the correct
    combination password. My PasswordSafe version is 3.14. The '.psafe3' is 0KB
    and '.ibak' is 46KB. The Support tracker is 2914161. I will appreciate very
    much if you could help me access the file.

  • DrK

    DrK - 2009-12-15

    First - I would backup (take a copy of and keep safe) the 'ibak' file!!!

    Then, PasswordSafe can open 'ibak' files. Just open it normally OR take a COPY
    of and save with a different name (e.g. mysafe.psafe3) and then try opening


  • Xa Dream

    Xa Dream - 2009-12-15

    Thanks David. I already made the backup of 'ibak' file.

    PasswordSafe can not open 'ibak' file even I am certain that I enter the right
    password. I tried to follow your advice and I still can not open the file. I
    also tried to install PasswordSafe with higher version (3.24) on another PC,
    but still can not open the file.

    Please help me solving this issue. Thanks

  • F D

    F D - 2010-01-15

    Have there been any updates to this issue? I am in the same situation as the
    others listed here. I have been using pwsafe for at least three years now, so
    I have a LOT of information in there that I can't afford to lose! Unlike some
    others, my .ibak is corrupt, too, so I have no backup of my data.

    Thank you!

  • DavyJones

    DavyJones - 2010-01-18

    I had the same issue and on version 3.14 on Vista. Incidentally, looks like
    the last few times the ibak was made, windows made shadow copies (under the
    previous versions tab under properties). The backups made by windows saved my

  • cookiejar

    cookiejar - 2011-03-06

    I have the same problem. ibak and dat file cannot be opened :( I have this
    programm since years, so I will be totally screwed without my passwords...
    should I email my dat file to corrruptedfile or something ? I
    would appreciate some help and I would be more than happy to reward it.

  • Rony Shapiro

    Rony Shapiro - 2011-03-06

    Hi Jonathan,

    The .dat file suffix is the default for the (very) old PasswordSafe file
    format. 3.x versions use .psafe3 as the file suffix, so you might want to look
    for files with that suffix as well.

    If you wish to send me your files directly for analysis, to see what, if
    anything, can be recovered, drop me a line: ronys at users dot sourceforge dot



  • umesh toprani

    umesh toprani - 2011-12-20

    My passwordsafe file (and backup) are corrupted - is there any way i can
    salvage the data?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks