Dis-allowing multiple instances (ubuntu-0.7)

Help
c.cobb
2011-12-08
2012-09-17
  • c.cobb

    c.cobb - 2011-12-08

    Thank you for working on the Linux version of your nice app. I use a launcher
    button for this, and often don't realize that I've already opened a password
    safe. The Java version that I was using earlier also has this issue and, for
    that, I hacked up a script to prevent multiple instances.

    As I'm starting finally to use your beta version, I notice this has the same
    issue -- deselecting the "Allow multiple instances" is not recognized. However
    a few mods to the earlier script solves this here as well, and it's now
    available on my website at
    http://ccobb.net/misc/java_pwsafe/

    This has only been tested on Ubuntu 10.04. It also includes support for a fix
    to the Ubuntu 10.04 library dependency issue for those who need it, which
    resolves the following error message.

    pwsafe: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required
    by pwsafe)

     
  • Rony Shapiro

    Rony Shapiro - 2011-12-09

    Thanks for the link to the script - nice work!

    Could you submit a bug report as to "Allow multiple instances" not working
    under Linux? This will help us get a fix out eventually.

    Cheers,

    Rony

    PS - you might want to check out the 'pgrep' command instead of 'ps | grep |
    grep -v'...

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks