Unable to add new Groups

Help
vsmith
2009-12-17
2012-09-17
  • vsmith

    vsmith - 2009-12-17

    Initially used latest version, then went back a few versions to v3.17. In
    both, I am unable to get the application to remember new Group(s) (and their
    associated Entries) that I added.

    They are there just fine when I add them. If I close Password Safe and reopen
    it, everything that was entered previously has mysteriously vanished in to Fat
    Air.

    I even tried "Save As..." to another database...same thing. The new data is
    simply gone upon opening the new database.

    I'm experiencing this fun and joy on Windows Vista (YUCK!) 32-bit.

    Any suggestions or resolutions would be most appreciated. I've used this
    program on WinXP for quite a while and never had anything remotely like this
    happen.

    And before you say "switch to Nested Tree View", I already knew about that,
    and yes, I am in that view. I'm not a newbie with this application, just have
    never had this weirdness occur before.

    Thanks.

     
  • vsmith

    vsmith - 2009-12-17

    Oh, one additional detail.

    After I add the new data to a database, I see that the "pwsafe.psafe3" file
    has had its date/time stamp updated, and also that the "pwsafe.ibak" file is
    there and current.

    So, it would appear that some sort of "restore-from-backup-file-upon-user-
    open-database" operation is being strangely done upon reopening the
    database...?

     
  • iflogic

    iflogic - 2009-12-20

    Not so much a reply as an affirmation of having the exact same problem.

     
  • Rony Shapiro

    Rony Shapiro - 2009-12-20

    Hi,

    Groups, as currently implemented, don't really "exist" until there's an entry
    associated with them. This means that saving a database with an empty group
    will result in the group "disappearing" when the database is reopened. This
    doesn't happen when there's at least one entry in the group.

    There is, however, an unfortunate bug in 3.20 - the default "save after
    add/edit" setting combined with adding a group causes the group to disappear
    as soon as it's added. To work around this, either disable the "Save after
    Add/Edit" option in Manage->Options->Backups, or add the group "implicitly" by
    typing the new groupname in the new entry's Group field.

    Sorry about the confusion. This will be fixed in the next version.

    Cheers,

    Rony

     
  • vsmith

    vsmith - 2009-12-21

    Thank you. Guess I had tried new Group/new Entry combination attempt on in
    3.20.

    Using 3.17, ensuring that a new Entry is added within the new Group, prior to
    closing the database is working.

    Thanks again.

     
  • jon

    jon - 2010-11-08

    I am a new user to Password Safe and am transferring from another product that
    only alllows a limited number of passwords and no structure. I have hit the
    bug that Rony descibes in vn 3.20, but am using vn 3.23 and it it's still
    there. I am trying to create a nice structure for all my passwords and then
    populate it. Do I really have to put at least one entry in each tree node
    before I can save the incremented structure? Please advise me. Thanks.

     
  • DrK

    DrK - 2010-11-08

    The bug that Rony mentioned in V3.20 is NOT in V3.23 - it has been fixed. With
    the Bug and the default "save after add/edit" setting, the new group
    disappeared immediately it was created. It doesn't anymore.

    And in answer to your question - if you save an database, then any empty
    groups will disappear. As explained before, the "Group" is just an artefact of
    the tree display - it does not really exist until there is an entry that has
    as group with this value..

    Options:

    1. Don't save the database until you have populated each new group with at least one entry, or
    2. Don't pre-add the groups but add them as you add a new entry, or
    3. Create a Text or XML file external to PasswordSafe with all your entries and then import it into an empty database (details of the format can be found in the Help file - or you can create a dummy database and export it and look at the resulting files), or
    4. Just add them into the root without any groups, save it, then either create the groups and drag the required entries into the correct structure or just edit them and update the group - the new group will be automatically created (note the Group name can be specified as something like "a.b.c" etc. to give a the required hierarchy of group "a", with sub-group "b" that has sub-group "c" etc.).

    If you do select option 3, then if you put your sensitive data into it for
    import, be sure you save it somewhere secure and that you erase it afterwards!
    Alternatively, just put dummy passwords in it so that it doesn't matter,
    import it and then edit the entries to place the real passwords (or other
    sensitive data) once safely in a PasswordSafe database.

    With the Import method, you can have multiple attempts by editing the import
    file and importing into an empty database that you do not bother to save until
    you are satisfied with the structure.

    David

     
  • jon

    jon - 2010-11-08

    Thanks David for your speedy help, I am getting on doing it basically as per
    your option 1. If my old utility would allow exporting, option 3 would have
    been nice. Thanks again.

     
  • SublimeSabrosa

    SublimeSabrosa - 2011-05-09

    Try going to Options and un-checking "Open database read-only by default".

    I had a similar issue editing passwords and creating new groups until I
    unchecked this.

     
  • AJ Scotka

    AJ Scotka - 2012-06-13

    I am using 3.28 (4783), not opening in read-only mode, have unchecked the save
    on "Save database immediately after Edit or Add" ...and the group is still
    disappearing as soon as I remove focus on the empty group. I cannot even save
    the group with a new name. I have to create new 'New Group' and immediately
    right click to add an entry. Or drag and drop to add entry.

     
  • Martin Rosoff

    Martin Rosoff - 2012-06-17

    I experienced the same problem with Password Safe v3.28 (4783) and was able to
    resolve the problem using the following steps:

    • Right click on any group and select, "Add Group". New Group will be created but do not change name of "New Group" beside yellow diamond shaped icon.
    • Right click on newly created Group beside yellow diamond shaped icon and select, "Add Entry".
    • Add Entry dialog box displays.
    • Within the "Add Entry" dialog box, change the name of the Group and change the name of the Entry in the "Title" field. Make sure you enter a Username and Password. Then Click OK.
    • Result: the New Group will move in the Tree Structure and show the name of the New Group and the Entry you've just created.

    martin

     
  • Rony Shapiro

    Rony Shapiro - 2012-06-17

    Release 3.29 will support persistent empty groups.

    If you can't wait a few days, you're welcome to test drive the pre-release
    version at

    http://pwsafe.org/tmp/3.29pre2/pwsafe-3.29pre2.exe

    Rony

     
  • Randy

    Randy - 2012-06-17

    I bought a new laptop over the weekend and had installed 3.28 on it, a Windows
    7 64 Bit sytem that is fully patched. My password safe is on a USB key. My
    password database was created on another system, I don't remember the verion.
    Today I attempted several times to add a group, but the group would disappear.
    What I did notice is that the last entry in my second group was renamed from
    Twitter to the group name I attempted to add. I was unable to rename Twitter
    back to Twitter, so I would exit Password Safe without saving. In one attempt,
    I did "save" and then exit. The group was not there when I reopened the
    database, and Twitter was back to Twitter, with the entry before Twitter now
    missing.

    I have updated to 3.29pre2 and I was able to create a new group and additional
    entries that were successfully saved and persisted to the next session.

     

Log in to post a comment.