Crash and Burn

  • Keith Mitchell

    Keith Mitchell - 2014-03-15

    I just downloaded Password Safe, only used it for a couple minutes, and it crashed and burned up the data. 64-Bit Win-7. Details.
    1. I opened PWS and created a new safe.
    2. I created a new Group.
    3. ALT-TAB to some other task and tried to return. The main window was missing from the task bar.
    4. I opened TaskManager-Applications and Password Safe was NOT running.
    5. I opened TaskManager-Processes and Password Safe was running.
    6. I stopped the running Password Safe process.
    7. I relaunched a fresh instance of Password Safe and tried to open my safe.
    8. I receive the error message that the database is in use.
    9. I since the database was NOT in use, and PWS was not running, I force-opened it read-write.
    10. I tried to add a new entry, and the group information that I created earlier was lost by the crash.
    11. Password Safe was not able to successfully recover from the initial crash with a restart.

    Any ideas how to recover and prevent future data loss?

  • SteveG23

    SteveG23 - 2014-03-15

    Not sure if this is what you're experiencing, but it may be.

    When you stop doing anything in the PasswordSafe window for more than a short time in Windows 7 it will "minimize" to the System Tray (not the taskbar). This does not automatically lock or close the file; the time delay to lock it is set in the Manage/Options screen, but when it minimizes to the System Tray it is not necessarily also locked. The same thing happens if you use the 'X' at the top right of the window to close it down - it is minimized to the System Tray but the application is not stopped and the file is not automatically locked. When this happens, it does not show as a running application in Task Manager - Applications, although it does show in TaskManager - Processes.

    If you try to open it fresh from the normal startup icon, you get that dialog box that the database is in use. When this happens, click the Exit button in that box, what you need to do is go to the System Tray, right-click on the PasswordSafe icon and select "Restore."

    I suspect that when you went to TaskManager - Processes and stopped the running instance, the file had not been locked and this may have corrupted it. Either that, or you were too fast to re-open it and the process had not fully stopped. I'm just guessing at that part, since it has no happened to me. I have been using PasswordSafe in Windows 7 for years, just switched to the 64-bit version of Windows 7, and have had all the symptoms you describe up to that point, but I always "Exit" that window and restore the application form the System Tray, and have never had a problem with the file.

    By the way, you also can make an extra copy of the file for safety just in case of glitches. I do this often.

  • Keith Mitchell

    Keith Mitchell - 2014-03-16

    Thanks Steve.

    I just recreated the most serious: the disappearing window. Your solution "Minimize to the System-Tray" was correct. I have never seen this activity. Thanks.

    I created a new group before I let it time out. The new group information was lost. I need to do more testing.

    Thanks for the confidence. That is a a big help. I have to eliminate "operator malfunctions" on my part first.


  • Rony Shapiro

    Rony Shapiro - 2014-04-06

    Thanks to Steve for his detailed explanation.

    The only thing I'd add is that you can configure PasswordSafe to minimize to the task bar rather than the system tray by clearing the "Put icon is System Tray" checkbox in Manage->Options->System.



Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks