Help save net neutrality! Learn more.
Close

URGENT: password safe not opening db file

Help
Anonymous
2006-03-13
2012-09-17
  • Anonymous - 2006-03-13

    This issue started just recently when I reinstalled windows. When I open my old db file using pwsafe and enter the passkey the program grabs over 1GB of virtual memory, and just hangs. I let it run overnight and when I returned in the morning it had an "Out of Memory" dialog on the screen. When I clicked OK it just sat there.

    I've been using pwsafe for over 2 years without a problem, until now, and ALL of my passwords are in this file! :-C I was using version 2.09 when the problem started, and upgraded to 2.16, but with the same result.

    I know it can read the file to some extent, because when I enter an incorrect passkey it states "Incorrect Passkey", as expected, but when I enter the correct passkey it simply grabs all the memory and hangs. So, it's obviously reading the file, but it never opens the db! :-C

    Has anyone seen this issue? Is there a fix?

     
    • Rony Shapiro

      Rony Shapiro - 2006-03-14

      Hi,

      What you're seeing is typical behaviour when passwordsafe reads a corrupt database. This is because the size of each field is encrypted as part of the data, and if the file is damaged, the decrypted size can become an absurdly large number.

      The best you can do in this case is to compile passwordsafe from source and run it under a debugger. This will at least allow you to recover al you passwords up to the corruption.

      Perhaps you've a backup copy of your database from before you reinstalled windows?

      Rony

       
      • Anonymous - 2006-03-15

        Would it be possible to correct the field size using a hex editor, since I know the password? I mean, the file is only 10KB in size. I would be more than willing to do so if I could recover all these passwords!

        Respectfully,

        Raven

         
      • Anonymous - 2006-03-15

        ronys wrote: "[..] compile passwordsafe from source and run it under a debugger [..]"

        Could you explain this with a step-by-step? I've got no idea how to compile this under WinXP, which debugger to use, or how to "run it under" a debugger.

         
    • Anonymous - 2006-03-15

      ronys wrote: "Perhaps you've a backup copy of your database from before you reinstalled windows?"

      I've already tried the backup with the exact same results.

       

Log in to post a comment.