Cannot Paste contents of clipboard into any field other than 'Notes'

Help
NSK
2013-01-03
2015-08-20
  • NSK

    NSK - 2013-01-03

    Using Password Safe V3.30 (5195) on Windows7 x64, I cannot paste into any field other than Notes.
    In each field a right click shows Paste as available - all other editing choices are greyed out.
    Have tried using both Ctrl+V and right click Paste, the field remains empty after taking the action.
    Have verified there is something to paste by first pasting into Notepad.
    Have tried both editing an exiting entry and during creation of a new entry.

    Any hints??

     
  • jon

    jon - 2013-01-03

    I have seen this and am glad what you want does not work. I accidentally tried to paste into the field holding the passsword and am mighty glad it did not work. I think it's best that the fields you mention have to be typed into in order to alter tem. HTH :-)

     
  • jimnms

    jimnms - 2013-01-03

    It sounds like your database in read only mode. I'm also using Password Save v3.30 (5195) on Win7 64-bit. I just tested this and I can paste into any field, using CTRL-V or right click/paste, whether editing or creating a new entry. If I switch the database to RO mode, it does as you describe, CTRL-V does nothing and right clicking shows paste available, but it does nothing. Although when in RO mode I can't paste to the Notes section, and you say you can paste to the Notes, which is odd.

    Check to make sure your database is in read/write mode by clicking File and selecting Change to R/W. If that doesn't work, check the permissions on the file and the directory you've stored the database file in to make sure you have read, write and modify permissions on it.

     
    • NSK

      NSK - 2013-01-04

      Thanks for your comments. It's good to know this isn't "works as designed".

      I have verified that the database is set to the default 'R/W', not 'R-O' mode.
      I tried toggling between the modes with closing/restart the app and rebooting, and am still unable to right-click/paste or ctrl-v.

       
  • Rony Shapiro

    Rony Shapiro - 2013-01-13

    Odd. This works fine for me on Win7 64bits. Copy, Paste from any field to any field in an entry's 'Edit Entry' dialog box.

    Can you try this with a new dummy database? If the problem persists, please submit a bug report (https://sourceforge.net/p/passwordsafe/bugs/new/) with the sample database and as many details as possible on how to duplicate the problem.

     
  • permon

    permon - 2015-08-20

    Hi,
    First time user - I am having this exact behaviour also ( database is R/W) version 3.36. I am using Windows Vista Business. Does anybody know if this matter was tracked down ?

     
    Last edit: permon 2015-08-20

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks