Import Plain Text ?

timbuk2
2006-03-10
2012-09-17
  • timbuk2

    timbuk2 - 2006-03-10

    I'm sure I'm not the only one that prior to finding Password Safe kept a long list of password information in a text file. I never liked the idea, even if I did keep it in an encrypted folder. I sure am glad I found Password Safe!

    I tried to import my plain text list using various delimiters (TAB, COMMA, etc.) and it's a real trial and error exercise to get anything to import at all. I even tried exporting my database, changing some of the info, and importing back into the database with very little success.

    If this feature works as described, then the help for this feature sure could use some examples to assist in formatting.

    Thanks again for a much needed program!

    -tb2

     
    • Ray

      Ray - 2006-05-12

      I was able to import with marginal success by doing the following:

      1) Organized the passwords I wanted to import into groups.

      2) Created a plain text file (in my case, CSV) for each group I wanted to import. The plain text file had 4 columns:

      1st column - Title field
      2nd column - Username
      3rd column - Password
      4th column - Notes (does not get imported, hence my statement of "marginal" success)

      3) Opened the import feature and selected Comma for the field separator.

      4) Selected Yes for Import Under Group and entered the name of the group I wanted to create.

      5) Imported the file.

      6) Repeated steps 2 - 5 for each group.

      Each group name was created successfully and the Title, Username and Password values were placed in the correct fields. I was never able to populate the Notes field but in my case I did not have any notes so this was acceptable.

      I had over almost 200 records to import so even though the import routine was a little frustrating, it did save me a ton of time.

      I hope this helps.

      • Ray
       
      • timbuk2

        timbuk2 - 2006-05-15

        az_cats:

        Thanks - I organized as you described and it did work. Thanks for taking the time to respond.

        -tb2

         
    • Nelson E. Ingersoll

      I agree... I am just now attempting to import my PalmOS KeyRing data and it isn't working. The errors provided are not particularly helpful either... "0 records read... Couldn't read 56 records." Filed under "Well duh!"

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks