Mac OS X users?

2012-12-29
2013-02-06
  • Mark Clayton

    Mark Clayton - 2012-12-29

    Is there anyone building and using pwsafe on Mac?

    I have OS X Mountain Lion, XCode 4.5.1 and wxWidgets 2.9.4. I finally got
    the git hub source to compile. I had to add several files to the xcode
    project and change a number of .c_str() to .wc_str(). I have limited
    experience with Mac UI and wxWindows, I'm more of a linux guy. I get a
    crash in wxStockGDI.GetFont on startup, via creating a new wxLocale.

    Any suggestions?

    Thanks.
    Mark Clayton
    --
    claytoncapers.blogspot.com
    www.mark-clayton.com

     
  • Rony Shapiro

    Rony Shapiro - 2013-01-12

    Hi John,

    The updated version of the PasswordSafe code is under Subversion, not Git, under
    svn://svn.code.sf.net/p/passwordsafe/code/trunk
    or
    https://svn.code.sf.net/p/passwordsafe/code/trunk

    If you have trouble building from there (per instructions in README.MAC.DEVELOPERS.txt), please submit a bug report.

     
    • Anonymous - 2013-01-15

      Thanks!! That almost did the trick. I built pwsafe64, debug, with xcode
      4.5.1, but using gcc 4.0 against wxWidgets 2.9.4. I'm already using
      wxWidgets 2.9.4 for another project and didn't want to complicate my life
      with 2 versions. I'm seeing an exception when a new wxLocale is created in
      PwsafeApp::initLanguageSupport(). My understanding is that this is a known
      bug in wxWidgets. I also see a failed assert that comes from creating a new
      xwIcon in PasswordSafeFrame::GetIconResource(). Clicking 'cancel' or 'no',
      pwsafe64 continues fine.

      I hope this helps someone else.

      Thanks,
      Mark Clayton

      --
      claytoncapers.blogspot.com
      www.mark-clayton.com

      On Sat, Jan 12, 2013 at 11:52 AM, Rony Shapiro ronys@users.sf.net wrote:

      Hi John,

      The updated version of the PasswordSafe code is under Subversion, not Git,
      under
      svn://svn.code.sf.net/p/passwordsafe/code/trunk
      or
      https://svn.code.sf.net/p/passwordsafe/code/trunk
      If you have trouble building from there (per instructions in
      README.MAC.DEVELOPERS.txt), please submit a bug report.

      Mac OS X users?https://sourceforge.net/p/passwordsafe/discussion/134800/thread/41b4edcb/?limit=25#fac9

      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/passwordsafe/discussion/134800/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/prefs/

       
  • avysha

    avysha - 2013-01-16

    Just for Info: current version 0.9 (5208) + wxMac-2.8.12 builds without problems on OSX 10.6.8 with Xcode 3.2.6 (llvm build).
    Does it make any sense yet to provide the binary for users who do not want to build by themselves ?

    This version is quite functional; i only noticed some minor usability issues
    (window focus not ok, DB locks but open edit-pane still shows password, problems with quiting while locked).

    If I would like to contribute - where should I start ?

    Thanks for this great application,
    Avy Sharell

     
    Last edit: avysha 2013-01-16
    • Rony Shapiro

      Rony Shapiro - 2013-02-06

      Hi Avy,

      Thanks for offering to help. I think the best way forward would be for you to automate the build process to generate a .app that users could install. Once this is in the code base, I can build, sign and upload it to the project's download area.

      Rony

       
  • David Hoerl

    David Hoerl - 2013-01-29

    My machine is running 10.8.2, I have Xcode 4.5.2, and am failing miserably to get this project to build. I got wxWidgets 2.9.4 to build just fine, and pulled the latest svn source for pwsafe today. I tried to get the pwsafe64-release to build, but get slews of errors, using the Xcode project. First, there is some issue with the config file not importing, or using the wrong macros; I ended up pasting the two paths created by the wx-config script into the two header search options in the target config. The project is set to use the llvm compiler not the llvm-gcc one, so I switched it and tried again. I'm going to upgrade to Xcode 4.6 shortly, so wanted to get this done while on 4.5, but the outlook is bleak. If 4.6 looks better I'll update this.

     
    • Anonymous - 2013-01-30

      David,

      With xcode 4.5.1, I didn't let xcode convert the project when it prompted
      me. That way Xcode continued to use gcc 4.0 instead of llvm-gcc. I built
      the debug version of pwsafe64 because that's the version of wxWidgets I
      already had for another project. I didn't need to add any paths to my
      project. Did you run the shell scripts beforehand to create
      the supplemental project files? Look for the README.MAC.DEVELOPERS.txt file
      in the main directory. The build instructions there got me going in the
      right direction. I had to modify one method so the application would run.
      Once you get it building, email me and I'll walk you through what I did.
      Other than that, the app has a few asserts here and there running but
      nothing that 'cancel' can't handle.

      Hope this helps. But I'm the first to admit I'm not OS X or wxWidgets
      experts, so ymmv.

      Mark

      --
      claytoncapers.blogspot.com
      www.mark-clayton.com

      On Tue, Jan 29, 2013 at 4:28 PM, David Hoerl dhoerl@users.sf.net wrote:

      My machine is running 10.8.2, I have Xcode 4.5.2, and am failing miserably
      to get this project to build. I got wxWidgets 2.9.4 to build just fine, and
      pulled the latest svn source for pwsafe today. I tried to get the
      pwsafe64-release to build, but get slews of errors, using the Xcode
      project. First, there is some issue with the config file not importing, or
      using the wrong macros; I ended up pasting the two paths created by the
      wx-config script into the two header search options in the target config.
      The project is set to use the llvm compiler not the llvm-gcc one, so I
      switched it and tried again. I'm going to upgrade to Xcode 4.6 shortly, so
      wanted to get this done while on 4.5, but the outlook is bleak. If 4.6
      looks better I'll update this.

      Mac OS X users?https://sourceforge.net/p/passwordsafe/discussion/134800/thread/41b4edcb/?limit=25#77dd

      Sent from sourceforge.net because you indicated interest in
      https://sourceforge.net/p/passwordsafe/discussion/134800/

      To unsubscribe from further messages, please visit
      https://sourceforge.net/auth/prefs/

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks