Password Safe 3.31 Crashes

t b
  • t b

    t b - 2013-07-25

    I am using Windows 7 Home Premium (32-bit) and PWS 3.31 on a desktop.

    Upon launching PWS I get a window stating that PWS has stopped working and here are the problem details. I have already re-installed PWS without any improvements. What else can I do?

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: pwsafe.exe
    Application Version:
    Application Timestamp: 518e0851
    Fault Module Name: pwsafe.exe
    Fault Module Version:
    Fault Module Timestamp: 518e0851
    Exception Code: c000001d
    Exception Offset: 00100a87
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

  • Rony Shapiro

    Rony Shapiro - 2013-07-27

    Does this happen even before you see the "Enter Safe Combination" window?

  • DrK

    DrK - 2013-07-27

    Exception Code: c000001d means illegal instruction.

    Probably an old processor that doesn't support SSE2 instructions.

    I think this was fixed in 3.32. If not, then it is fixed in the current code base.

    • t b

      t b - 2013-08-03

      Yes, my processor is a Pentium III (32-bit) and is approx. 13 years old...
      Where can I get v. 3.32? All I see available for download is v. 3.31.

  • Rony Shapiro

    Rony Shapiro - 2013-08-05

    Oops. 3.32 hasn't been released yet. Will set up a preview version for download in a few days.


  • Murray Stentiford

    Trying to run PWS 3.31 on my 9 year old AMD Athlon XP 2600+ CPU with Win XP SP3, it stopped loading before executing, with the Windows error message "Password Safe Application has encountered a problem and needs to close."

    The exception code was 0xc000001d, CPU version 000006A0, CPU Feature Code 0383FBFF, CPU AMD Feature Code C1C3FBFF. PWS FileVer and ProdVer both

    This CPU doesn't have SSE2 instructions, from other tests I've done.

    PWS versions earlier than 3.31 worked fine, and 3.32pre works fine. Thanks for the link to it!

  • t b

    t b - 2013-10-13

    Installing v. 3.32 solved my problem!


Log in to post a comment.