#1104 ubuntu 0.91BETA amd64 debian package requires ia32-libs

v1.0_(example)
closed
nobody
None
1
2013-08-18
2013-07-01
SteC
No

i recently updated my Ubuntu machine from LUCID to PRECISE. when i attempted to install the passwordsafe 0.91BETA package for amd64, dpkg complained that the package requires ia32-libs and left the package unconfigured. attempting to install ia32-libs created a serious conflict with other installed applications; i inspected the executable that's installed, and it appears to be a native 65-bit build, and ldd indicates that all shared objects are installed, so the dependency on ia32-libs appears vestigial. is that true? if so, can this dependency be removed from the package?

Discussion

  • Thomas Waldmann

    Thomas Waldmann - 2013-08-05

    We had a "password manager" workshop yesterday and one guy tried password safe 0.91 on ubuntu 12.04lts 64bit. it didn't install, complaining about libxerces.

    After reading this issue, we tried to also install ia32-libs, but somehow it didn't resolve the issues.

    On my machine, on 12.04 32bit, it just worked without problems.

     
  • Rony Shapiro

    Rony Shapiro - 2013-08-18

    The dependency on ia32-libs is indeed vestigal and will be removed from the next releases deb packages of Ubuntu and Mint 64bit.

    Thanks!

    Rony

     
  • Rony Shapiro

    Rony Shapiro - 2013-08-18
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks