#14 t-error: can not create alpha list.

v0.17beta
closed-fixed
GUI (11)
5
2009-03-02
2005-09-07
Geoffrey
No

I was using CPM 0.11 on another Gentoo computer, and cpm
worked fine. I copied the ebuild over, and recompiled
on this computer
and whenever the GUI tries to display an empty list
(such as just after adding a new site, etc)
CPM crashes and prints this error:
"t-error: can not create alpha list."

I upgraded to cpm 0.17 beta, but its still doing the
same thing.

The problem might be due to the fact that I'm using the
4.9.11.20031210-r1 release of cdk... Perhaps there is a
bug in
CDK, or perhaps cpm is asking CDK to sort an empty
list, which violates CDK's API pre-conditions.

Either way, downgrading to the older release of CDK
works as a temporary fix.

Discussion

  • Harry Brueckner

    Harry Brueckner - 2005-09-07
    • milestone: --> v0.17beta
     
  • Harry Brueckner

    Harry Brueckner - 2005-09-07

    Logged In: YES
    user_id=1175558

    What does "ulimit -l" show for "max locked memory" ? In case
    it's set too low (I think it defaults to 32k on Gentoo),
    raise it to something around 5120k or higher.

    Does this t-error message also appear if you run cpm as root?

     
  • Geoffrey

    Geoffrey - 2005-09-07

    Logged In: YES
    user_id=935861

    yes, ulimit -l is 32 by default... however, increasing it
    doesn't affect the bug...

    As root:
    With ulimit -l 32 and with ulimit -l 5120, the same exact
    thing happens
    as running cpm as a normal user:
    "t-error: can not create alpha list."
    Like I said earlier, this only occurs when cpm is trying to
    display a list of 0 items... I can view existing usernames
    and passwords just fine, but if I were to press enter on a
    password to display "level 5" or whatever, cpm crashes
    because there isn't any children to display, or if I were to
    add a new host to cpm and then select it and hit enter, the
    same would occur.

    --

    Back to the ulimit thing....
    As a normal user `ulimit -l 5120` produces
    "bash: ulimit: max locked memory: cannot modify limit:
    Operation not permitted"

    Since this is a single-user system with no swap, I just ran
    `chmod u-s cpm`
    so that cpm would get around the mem problem,but I'm not
    sure how to globally increase the ulimit since it's a
    builitin shell command that only modifies itself and child
    processes. I believe /etc/conf.d/local.start is spawns a
    sub-shell, so putting the line there probably wouldn't work.

     
  • Harry Brueckner

    Harry Brueckner - 2005-09-07

    Logged In: YES
    user_id=1175558

    Hmm, maybe this CDK has yet another internal handling of
    something. I tested cpm with quite some CDK versions so far
    but no r1 versions.
    Maybe you could send me the source of this CDK version via
    mail so I could try to reproduce this bug.

    Thanks alot!

     
  • Geoffrey

    Geoffrey - 2005-09-07

    Logged In: YES
    user_id=935861

    The source file can be found at
    http://gentoo.osuosl.org/distfiles/cdk-4.9.11-20031210.tgz

    The ebuild compiles it as follows:
    LD_FLAGS=-fPIC
    configure --with-ncurses --with-libtool
    ... along with some installation-path specific options.

     
  • Harry Brueckner

    Harry Brueckner - 2005-09-08

    Logged In: YES
    user_id=1175558

    I tried this version of CDK and it seems that I got a
    problem with all CDK versions close to version 5.
    I'll look into this ASAP and roll out a new release when
    it's fixed.

     
  • Harry Brueckner

    Harry Brueckner - 2005-09-08

    Logged In: YES
    user_id=1175558

    I verified this bug with any version >4.9.9 and it seems
    that CDK behaves differently since then. It even looks like
    CDK can not handle empty alphalists (which is the name of
    the widget in question).

    I emailed the author of CDK about this issue, awaiting his
    response.

     
  • Harry Brueckner

    Harry Brueckner - 2005-09-09
    • status: open --> closed
     
  • Harry Brueckner

    Harry Brueckner - 2005-09-09

    Logged In: YES
    user_id=1175558

    I emailed the author of the CDK library and he confirmed
    that this is an "unanticipated incompatibility".

    You must run a CDK version before cdk-4.9.11. I modified the
    configure script of cpm to verify the used version and break
    the build process in case it finds a newer version.

    For now all version >= 4.9.10 are considered to be broken.

     
  • Harry Brueckner

    Harry Brueckner - 2009-03-02
    • status: closed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks