Password encoding and linux

Help
Anonymous
2013-11-16
2013-12-19
  • Anonymous - 2013-11-16

    Hello,
    I'm using PasswdSafe on android together with the linux version on the laptop. Some time ago I swithed from java version to the beta from
    http://sourceforge.net/projects/passwordsafe/files/Linux-BETA/
    Version 0.9 worked fine but apparently versions 0.91 and 0.92 changed the encoding used for storing the password. If I open the file on android and ask for password display, everything looks fine. But the password is not accepted when I try to copy and paste it. On the password editing screen I can see that there is an extra character in the password string (must be some control character?). Once the last character of a password string is deleted, the password is usable again. I have tried to change the password encoding setting in passwdsafe but it does not seem to help.

    I understand that the issue is likely due to the linux version of passwordsafe and will contact its developers but I would appreciate if it could also be fixed on the android side.

     
    • Jeff Harris

      Jeff Harris - 2013-11-16

      The problem is likely in the Linux version. They likely are storing the final null character used in C strings in the field's value which is not correct.

      The password encoding scheme in the app is used to specify the encoding for the password when opening the file. It does not apply to passwords stored in the file itself.

       
    • Jeff Harris

      Jeff Harris - 2013-11-16

      Also, can you attach a sample file with the problem? Password policies can have the same problem, and I was able to work around the bug. Perhaps I can do the same in this case as well.

      Jeff

       
  • Anonymous - 2013-11-19

    I'm attaching a sample file with a single password. The file access password is "test" and the password stored in the file is "test123"
    Thanks,
    Yuri

     
    • Jeff Harris

      Jeff Harris - 2013-12-08

      The file does that the trailing null character as I suspected. I've added notes to the post on the PC forum about the issue.

       
  • Anonymous - 2013-12-19

    Just in case anyone else is interested: linux PasswordSafe had a patch committed that fixes this, I assume it will work in the next beta.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks