Trouble gathering results

Help
2009-06-19
2013-04-29
  • Woody Anderson

    Woody Anderson - 2009-06-19

    I use the PartCover GUI and I've saved several configurations for easy use.  However, after updating to NUnit 2.5, I can't seem to get any output from my tests.  I've even tried the following rule

    +[*]*

    which should include everything, but my namespace is not listed.  any ideas what could be wrong?  I know that with NUnit 2.5 they changed the directory structure of the exacutable, but I don't know if that would cause this problem.  Any help is appreciated.

    Thanks
    Woody

     
    • Woody Anderson

      Woody Anderson - 2009-06-19

      Here are my complete settings from the Run Target... dialog in the GUI

      Target
           Executable File = C:\Program Files\NUnit 2.5\bin\net-2.0\nunit.exe
           Working Directory = C:\Program Files\NUnit 2.5\bin\net-2.0
           Working Arguments =

      Rules
      +[*]*

      None of the loggin options are checked.

      I've tried a more specific rule with no change. I figured +[*]* would find everything.  Instead it finds everything but my stuff.

       
    • Loginov Oleg

      Loginov Oleg - 2009-06-19

      what partcover version do you use?

       
    • Woody Anderson

      Woody Anderson - 2009-06-23

      It's version 2.3.0.18745.

      This seemed to become more of a problem when I installed the very latest build.

       
      • Loginov Oleg

        Loginov Oleg - 2009-06-23

        Ok. then some more questions

        For 2.3.0.18745:
        1) Did you use console version of NUnit or gui one?

        For latest:
        2) could you please describe your problems? It will help in identifying the roots

         
    • Woody Anderson

      Woody Anderson - 2009-06-25

      2.3.0.18745 is the latest version I'm referring too.  I thought it was the latest, but it is more recent than what I had before.  I do not know which version I had before.

      I was using the gui. I haven't messed with the command line.

      thanks

       
      • Loginov Oleg

        Loginov Oleg - 2009-06-25

        nunit gui  version runs test in another AppDomain (specific for .NET CLR).
        I'm not sure if 18745 manage with that, but 35109 - does gather infromation if assembly was loaded in other domain too.

        So here are two ways: use NUnit console with 18745, or NUnit gui with 35109

         
    • Woody Anderson

      Woody Anderson - 2009-07-06

      Thanks, upgrading to 35109 did the trick.  I appreciate the help.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks