After typing cmake ../hugin-2012.0.0 on my Terminal, I get : 

[...]

-- WARNING: you are using the obsolete 'PKGCONFIG' macro, use FindPkgConfig

[...]

-- libpano13 version: 2.9.18 major 2 minor 9 patch 18

[...]

-- ZThread library not found. falling back to included copy

-- flann library not found. falling back to included copy

-- Found Lensfun: /opt/local/include

*** Will install application bundles in /usr/local/Applications, set INSTALL_OSX_BUNDLE_DIR to change the location

-- Using shared internal libraries

-- Python libs version: 2.7.2

-- Install Python libs into /Library/Python/2.7/site-packages

-- Current source dir = /Users/[username]/hugin

-- Configuring done

-- Generating done

-- Build files have been written to: /Users/[username]/hugin-2012.0.0


I don't know how to set INSTALL_OSX_BUNDLE_DIR, how to install flann-1.8.3 and how to install Python libs into /Library/Python/2.7/site-packages (what package with easy_install ?). When I compile ZThread-2.3.2, after make instruction, I get :


[]

make[3]: *** [AtomicCount.lo] Error 1

make[2]: *** [all-recursive] Error 1

make[1]: *** [all] Error 2

make: *** [all-recursive] Error 1


After the make instruction, in hugin-2012.0.0, I get an error concerning hugin-2012.0.0/src/foreign/zthread/include/zthread/Guard.h. I solved the problem by defining the function createScope as a static bool instead of a static void function. Nonetheless I still have errors after the make instruction and I actually get :

[]


make[2]: *** [src/tools/CMakeFiles/hugin_hdrmerge.dir/hugin_hdrmerge.cpp.o] Error 1

make[1]: *** [src/tools/CMakeFiles/hugin_hdrmerge.dir/all] Error 2

make: *** [all] Error 2


Thanks a lot for your help.