Right click sftp not working.

Help
Ozan Uzun
2013-03-10
2013-08-16
  • Ozan Uzun

    Ozan Uzun - 2013-03-10

    Hi,

    My version information is the following;

    Redhat 6.3 2.6.32-279.19.1.el6.x86_64  kernel, pac version pac-4.5.1.5-2.x86_64.

    Remote server supports sftp and ssh. Every scenerio works with native ssh client.

    But when I click open sftp tab.

    CONNECTING WITH 'server' =->

    Attaching to 22…
    exec: 22: No such file or directory
    Couldn't read packet: Connection reset by peer

    <-= DISCONNECTED (PRESS <ENTER> TO RECONNECT)

    When I create a sftp session, that is not working,too.

    On the console I got the following message all the time ( might be irreveland)
    GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)' at /opt/pac/lib/PACUtils.pm line 1400.
    GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed at /opt/pac/lib/PACUtils.pm line 1400.

     
  • David Torrejón Vaquerizas

    Can you please send me the output of "sftp -v" from command line?
    - David.

     
  • Ozan Uzun

    Ozan Uzun - 2013-03-12

    I hope I  understand you correctly

    just sftp -v is not a valid option

    $ sftp -v
    usage: sftp   
                 
                  host
           sftp host
           sftp host[:dir]
           sftp -b batchfile host

    $ sftp -v user@localhost
    Connecting to localhost…
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug
    ..
    ..
    ..
    asks for password after that

    debug1: Authentication succeeded (password).
    debug1: channel 0: new
    debug1: Requesting no-more-sessions@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env XMODIFIERS = @im=ibus
    debug1: Sending env LANG = en_US.utf8
    debug1: Sending subsystem: sftp
    sftp>

     
  • David Torrejón Vaquerizas

    Hmmm…

    What kind of "old" openssh package are you using?
    This is my sftp -v output:

    usage: sftp   
                
                
               host
           sftp host
           sftp host[:dir]
           sftp -b batchfile host

    It looks pretty different… (v1:6.0-p1)

     
  • Ozan Uzun

    Ozan Uzun - 2013-04-05

    Actually it is a redhat 6.3  linux workstation.

    My versions are the following;

    openssh-server-5.3p1-81.el6_3.x86_64
    openssh-5.3p1-81.el6_3.x86_64
    openssh-clients-5.3p1-81.el6_3.x86_64

     
  • voltair_s

    voltair_s - 2013-07-19

    Any updates on this? I am getting the same thing with Centos 6.4.

    Running very simlar packages.
    openssh.x86_64 5.3p1-84.1.el6
    openssh-clients.x86_64 5.3p1-84.1.el6
    openssh-server.x86_64 5.3p1-84.1.el6

     
  • voltair_s

    voltair_s - 2013-08-16

    Ok so what ssh server/clients has this been tested against so that I can at least try to get this working on my side.

    Cheers,

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks