PAC dont use xfreerdp

Help
2012-10-25
2013-04-23
  • problemmagnet

    problemmagnet - 2012-10-25

    Hello,

    1. I use the latest rpm and PAC says: sh rdesktop not found when i configure a RDP Session. Rdesktop is not installaled. I use xfreerdp. When i modify the pac_conn (remove the rdesktop entrys) its work fine
    2. It is possible to implemend the tab View  for xfreerdp like rdektop?

     
  • David Torrejón Vaquerizas

    Hi!
    Sorry, there is no way (rdesktop has a "-X <window_ID>", which allows embeding into PAC's widgets).

    - David.

     
  • problemmagnet

    problemmagnet - 2012-10-26

    Thanks for answer.  for 2.
    xfreerdp have the same Option in new Versions. When i see it right, this Options are set in PACMethod_xfreerdp.pm?

    But back to 1. I only installes xfrerdp but pac search for rdesktop and give the error in Connection Window: sh: rdesktop not found.

     
  • David Torrejón Vaquerizas

    Doh!
    Yes, you are in reason… newer xfreerdp versions bring newer features… :(
    Ok, let me work on it! :)

    - David.

     
  • problemmagnet

    problemmagnet - 2012-11-06

    Hello,

    i see the new Version but i have bad news. Tab don´t work :(
    I see this in .config/pac/tmp:
    X Error of failed request:  BadWindow (invalid Window parameter)
      Major opcode of failed request:  7 (X_ReparentWindow)
      Resource id in failed request:  0x60818822
      Serial number of failed request:  40
      Current serial number in output stream:  40

    2. pac_conn only try rdesktop (i comment the line out in pac_conn. After that its work.
    My System:
    RHEL WS 6.3

     
  • David Torrejón Vaquerizas

    Hi!
    Sorry, but I could not get freerdp working in an embedded tab (despite I has the option, there may be som kind of bug with Gtk2 or something)
    Sorry :(

    For PAC to use freerdp instead rdesktop, simply uninstall rdesktop. That should do the job.

    - David.

     
  • problemmagnet

    problemmagnet - 2012-11-07

    I  don´t have install rdesktop. That is the Problem. When I try i become:
    sh: rdesktop: Kommando nicht gefunden. (command not found)

     
  • David Torrejón Vaquerizas

    Hi!
    Please, update to PAC 4.4.1.1, and try again (re-creating your RDP connection), with both freerdp and rdekstop (taking into account that if rdesktop binary is installed, it will be preferred over freerdp).

    - David.

     
  • problemmagnet

    problemmagnet - 2012-11-07

    1. Sorry, but same Problem. I don´t install rdesktop (i check it with rpm -qa, which rdesktop and find) but i become the error
    "sh: rdesktop command not found)"
    2. I just need the tab Option (to much Windows).
    Can i see some debug Informations when i start it? When i have so time, i can try so search for some Reasons.
    Thanks for your help

     
  • Anonymous - 2013-03-10

    Perseo22

    $ xfreerdp --help
    FreeRDP - A Free Remote Desktop Protocol Client
    See http://www.freerdp.com for more information
    Usage: xfreerdp [options] server:port
      -0: connect to console session
      -a: set color depth in bit, default is 16
      -c: initial working directory
      -D: hide window decorations
      -T: window title
      -d: domain
      -f: fullscreen mode
      -g: set geometry, using format WxH or X% or 'workarea', default is 1024x768
      -h: print this help
      -k: set keyboard layout ID
      -K: do not interfere with window manager bindings
      -m: don't send mouse motion events
      -n: hostname
      -o: console audio
      -p: password
      -s: set startup-shell
      -t: alternative port number, default is 3389
      -u: username
      -x: performance flags (m[odem], b[roadband] or l[an])
      -X: embed into another window with a given XID.
      -z: enable compression
      --app: RemoteApp connection. This implies -g workarea
      --ext: load an extension
      --no-auth: disable authentication
      --from-stdin: unspecified username, password, domain and hostname params are prompted
      --no-fastpath: disable fast-path
      --gdi: graphics rendering (hw, sw)
      --no-osb: disable offscreen bitmaps
      --no-bmp-cache: disable bitmap cache
      --plugin: load a virtual channel plugin
      --rfx: enable RemoteFX                                                                              
      --rfx-mode: RemoteFX operational flags (v[ideo], i[mage]), default is video
      --nsc: enable NSCodec (experimental)
      --disable-wallpaper: disables wallpaper
      --composition: enable desktop composition
      --disable-full-window-drag: disables full window drag
      --disable-menu-animations: disables menu animations
      --disable-theming: disables theming
      --no-rdp: disable Standard RDP encryption
      --no-tls: disable TLS encryption
      --no-nla: disable network level authentication
      --ntlm: force NTLM authentication protocol version (1 or 2)
      --ignore-certificate: ignore verification of logon certificate
      --sec: force protocol security (rdp, tls or nla)
      --secure-checksum: use salted checksums with Standard RDP encryption
      --version: print version information
    

    Look at -X

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks