Install in opensuse 12.2 ??

Help
Anonymous
2013-01-31
2013-04-23
  • Anonymous - 2013-01-31

    I can't install pac-manager in OpenSuse 12.2. I can't resolve dependences perl-Gtk2-Ex-Simple-List

    Regards

     
  • Anonymous - 2013-01-31

    Perl API version v5.14.0 of Gnome2::Vte does not match v5.16.0 at /usr/lib/perl5/5.16.0/x86_64-linux-thread-multi/DynaLoader.pm line 213.
    Compilation failed in require at /home/user/pac/lib/PACTerminal.pm line 49.
    Compilation failed in require at /home/user/pac/lib/PACMain.pm line 50.
    BEGIN failed-compilation aborted at /home/user/pac/lib/PACMain.pm line 50.
    Compilation failed in require at ./pac line 35.
    BEGIN failed-compilation aborted at ./pac line 35.

     
  • David Torrejón Vaquerizas

    Hi!

    Ok, it looks like I'm having some problem with Fedora 18 and Virtualbox… :(
    I need you to:

    - install perl dependencies:
        ExtUtils::Depends not installed
        ExtUtils::PkgConfig not installed
        vte-dev (Vte development package)
    (I don't know how they are named in RPM idiom)

    Then:
    wget http://search.cpan.org/CPAN/authors/id/X/XA/XAOC/Gnome2-Vte-0.10.tar.gz
    tar xvfz Gnome2-Vte-0.10.tar.gz
    cd Gnome2-Vte-0.10
    perl Makefile.PL
    make

    Once finished (a couple of seconds!), please, simply send me
    the "blib/arch/auto/Gnome2/Vte/Vte.so" generated binary, so I may include it
    in next PAC releases).

    Thank you so much!!

     
  • Anonymous - 2013-02-01

    Hello,

    Thanks, but I continued with install problems:

    perl Makefile.PL
    Including generated API documentation…
    Checking if your kit is complete…
    Looks good
    Unrecognized argument in LIBS ignored: '-pthread'
    Writing Makefile for Gnome2::Vte
    Writing MYMETA.yml and MYMETA.json

    userz@linux-5x81:~/Descargas/Gnome2-Vte-0.10> make
    cp build/IFiles.pm blib/arch/Gnome2/Vte/Install/Files.pm
    cp /home/userz/Descargas/Gnome2-Vte-0.10/build/vte2perl.typemap blib/arch/Gnome2/Vte/Install/vte2perl.typemap
    cp build/vte2perl-autogen.h blib/arch/Gnome2/Vte/Install/vte2perl-autogen.h
    cp vte2perl.h blib/arch/Gnome2/Vte/Install/vte2perl.h
    cp Vte.pm blib/lib/Gnome2/Vte.pm
    cp build/vte2perl-version.h blib/arch/Gnome2/Vte/Install/vte2perl-version.h

    In file included from /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:45:0,
                     from ./vte2perl.h:24,
                     from xs/Vte.xs:21:
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2308:3: error: unknown type name ‘GdkRegion’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2311:3: error: unknown type name ‘GdkRegion’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2312:3: error: unknown type name ‘GdkRegion’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2313:3: error: unknown type name ‘GdkRegion’
    In file included from ./vte2perl.h:24:0,
                     from xs/Vte.xs:21:
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:66:30: error: unknown type name ‘GtkObject’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:74:1: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:76:1: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:80:22: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:81:28: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:85:24: error: unknown type name ‘GdkGCValues’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:86:32: error: unknown type name ‘GdkGCValues’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:86:49: error: unknown type name ‘GdkGCValuesMask’
    make: ***  Error 1

     
  • irraz

    irraz - 2013-02-05

    Thanks, but I am not lucky, 

    Gtk2-Ex-Simple-List same install correctly:

    Gtk2-Ex-Simple-List-0.50> sudo make install
    Appending installation info to /usr/lib/perl5/5.16.0/x86_64-linux-thread-multi/perllocal.pod
    

    But, when I try to install Gnome2-Vte-0.10 I get the same error:

     perl Makefile.PL 
    Including generated API documentation...
    Unrecognized argument in LIBS ignored: '-pthread'
    Writing Makefile for Gnome2::Vte
    Writing MYMETA.yml and MYMETA.json
    sjimenez@linux-5x81:~/Descargas/Gnome2-Vte-0.10> perl make
    Can't open perl script "make": No existe el fichero o el directorio
    sjimenez@linux-5x81:~/Descargas/Gnome2-Vte-0.10> make
    Skip blib/arch/Gnome2/Vte/Install/Files.pm (unchanged)
    Skip blib/arch/Gnome2/Vte/Install/vte2perl.typemap (unchanged)
    Skip blib/arch/Gnome2/Vte/Install/vte2perl-autogen.h (unchanged)
    Skip blib/arch/Gnome2/Vte/Install/vte2perl.h (unchanged)
    Skip blib/lib/Gnome2/Vte.pm (unchanged)
    Skip blib/arch/Gnome2/Vte/Install/vte2perl-version.h (unchanged)
    [ XS xs/Vte.xs ]
    [ CC xs/Vte.c ]
    In file included from /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:45:0,
                     from ./vte2perl.h:24,
                     from xs/Vte.xs:21:
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2308:3: error: unknown type name ‘GdkRegion’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2311:3: error: unknown type name ‘GdkRegion’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2312:3: error: unknown type name ‘GdkRegion’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl-autogen.h:2313:3: error: unknown type name ‘GdkRegion’
    In file included from ./vte2perl.h:24:0,
                     from xs/Vte.xs:21:
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:66:30: error: unknown type name ‘GtkObject’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:74:1: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:76:1: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:80:22: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:81:28: error: unknown type name ‘GdkBitmap’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:85:24: error: unknown type name ‘GdkGCValues’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:86:32: error: unknown type name ‘GdkGCValues’
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/Gtk2/Install/gtk2perl.h:86:49: error: unknown type name ‘GdkGCValuesMask’
    make: *** [xs/Vte.o] Error 1
    

    Any idea?

    Regards,

    Sergio

     
  • irraz

    irraz - 2013-02-05

    I found Vte.so in my system:
    /usr/lib/perl5/vendor_perl/5.16.0/x86_64-linux-thread-multi/auto/Gnome2/Vte/Vte.so

     
  • irraz

    irraz - 2013-02-06

    Hi perseo22 :)

    Yesterday, I change Vte.so of my OpenSuse to Vte.so in de pac directory and now it's works.
    But, keepassX functions nots works…

    This issue has resolved. Thanks you very much.

    Irracional

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks