linux debug help

Help
ben ouyang
2011-04-03
2013-05-28
  • ben ouyang

    ben ouyang - 2011-04-03

    Hi all:
       I have encountered a problem when start to debug p7zip. I added an option '-g' to makefile.

    EFILE_SOURCE -D_REENTRANT -DENV_UNIX -D_7ZIP_LARGE_PAGES -fPIC -DEXTERNAL_CODECS -DUNICODE -D_UNICODE -g -c  -I. -I../../../myWindows -I../../../ -I../../../include_windows ../../Archive/PeHandler.cpp
    ../../Archive/PeHandler.cpp

       However, when i load the 7z into gdb. It shows "no debugging symbols found". What should i do??

     
  • Martin Lemke

    Martin Lemke - 2011-04-03

    I guess you should use -ggdb instead, if it is a gcc compiler.

     
  • my p7zip

    my p7zip - 2011-04-12

    You must remove the '-s' flag to keep debugging symbols.

    When I want to debug, I edit the makefile.machine file :
    OPTFLAGS=-g2
    and I remove '-s' in ALLFLAGS.

     

Log in to post a comment.