#7 Building v4.12 under NetBSD >=1.5.2

closed-accepted
my space
None
5
2004-12-02
2004-11-18
Jason White
No

Using "makefile.freebsd" will work for versions of
NetBSD prior to 1.5.2 as those version contains libc_r.
Versions 1.5.2 and later seem to just use libpthread.
Attached makefile.netsd contains modifications to
LOCAL_LIBS. Tested under NetBSD 2.0_RC5 (gcc 3.3.3)
using gmake with target "7za" only.

Discussion

  • Jason White

    Jason White - 2004-11-18

    NetBSD makefile, modified for 1.5.2 and later.

     
  • Jason White

    Jason White - 2004-11-18
    • summary: Building under NetBSD >=1.5.2 --> Building v4.12 under NetBSD >=1.5.2
     
  • my space

    my space - 2004-12-02
    • assigned_to: nobody --> myspace
    • status: open --> closed-accepted
     
  • my space

    my space - 2004-12-02

    Logged In: YES
    user_id=336051

    Your makefile.netbsd will be added in the next version of p7zip.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks