Can't launch .exe after downloading

  • Jeff Schnitter

    Jeff Schnitter - 2007-04-25

    Hi there,

    I love the sfx task.  It's exactly what I'm looking for.  I have a simple installer -- it's an Ant script that is launched by a simple DOS batch file.  I put everything into a self-extracting exe using the sfx task.  I am able to build and launch the self-extracting executable and my setup.bat file runs successfully.

    I'm having a problem now that I've posted the self-extracting executable on a web server.  When I download in Firefox and click on the 'Open' link in the Downloads window, I get an error box that says ERROR Cannot open my.exe.  I get a similar problem with Internet Explorer.  I've tried all 4 types of install modes that will work on Windows and get similar errors with all.

    Anyone seen this behavior before?  Any suggestions on how to debug?

    Thanks in adavance and thanks for a really cool tool.

    Jeff Schnitter

    • Jeff Schnitter

      Jeff Schnitter - 2007-04-26

      Additional information . . .

      It seems that the problem may be that the executable cannot be found unless the current directory is the directory where the executable is located.  For example, I tried this in a DOS Window on Windows XP:

      - created test.exe in c:\temp\test1
      - run test.exe -> works fine
      - make c:\temp\test2 the current directory
      - run ..\test1\test.exe

      I get an error that test.exe cannot be found.

      I'm guessing that the code assumes the executable is in the current directory.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks