Ovaldi RPM installation libstdc++ issue

Help
2011-12-08
2013-06-12
  • Display nameRedBaron

    Hi,
    I am trying to install Ovaldi using the rpm provided on this site. I tried installing the ovaldi-libs package first but the following errors came-
    error: Failed dependencies:
    libstdc++.so.6 is needed by ovaldi-libs-5.10.1-1.i386
    libstdc++.so.6(CXXABI_1.3) is needed by ovaldi-libs-5.10.1-1.i386
    libstdc++.so.6(GLIBCXX_3.4) is needed by ovaldi-libs-5.10.1-1.i386

    I already have libstdc++.so.6 and libstdc++.so.6.0.13 in /usr/lib64. I even created a link to these files in /usr/lib but to na avail.
    Any help in resolving the issue will be appreciated.

     
  • Sandeep Rathan

    Sandeep Rathan - 2011-12-08

    Looks like libs present on your system are 64 bit and the rpm you are using requires 32 bit libraries. Can you try installing 32 bit libstdc++ libraries ..

     
  • Display nameRedBaron

    Thanks a ton…that fixed it

     
  • Display nameRedBaron

    Well there is another problem. I could install the libs but when I try to install ovaldi. I get the following error
    # rpm -ivh ovaldi-5.10.1.el5.i386.rpm
    error: Failed dependencies:
    liblber-2.3.so.0 is needed by ovaldi-5.10.1-1.i386
    libldap-2.3.so.0 is needed by ovaldi-5.10.1-1.i386
    librpm-4.4.so is needed by ovaldi-5.10.1-1.i386
    librpmdb-4.4.so is needed by ovaldi-5.10.1-1.i386
    librpmio-4.4.so is needed by ovaldi-5.10.1-1.i386

    I have already installed 32-bit versions ldap and rpm packages. Any pointers

     
  • Sandeep Rathan

    Sandeep Rathan - 2011-12-08

    Check if the package versions are matching. If yes check for the file names ovaldi is looking for. If they are not present create a soft link.

     

Log in to post a comment.