#26 Install problem after server down

OPT_1.X_(Max)
open
nobody
None
5
2006-12-06
2006-12-06
No

Hi folks,
we are using since 2 years OPT and its an very nice program. Bt today wa my my server brocken, so I had to install new OS (Suse 9.3 / apache 2/ php 5) and I'm not able to run the system. I'm gtting always zhis error message

[client 172.22.124.112] PHP Notice: Use of undefined constant _ - assumed '_' in /srv/www/htdocs/opt/include/general.php on line 804
[client 172.22.124.112] PHP Notice: Undefined variable: OPT_no_globals in /srv/www/htdocs/opt/include/general.php on line 1010
[client 172.22.124.112] PHP Notice: Undefined variable: HTTP_GET_VARS in /srv/www/htdocs/opt/include/general.php on line 1011
[client 172.22.124.112] PHP Warning: extract() [<a href='function.extract'>function.extract</a>]: First argument should be an array in /srv/www/htdocs/opt/include/general.php on line 1011
[client 172.22.124.112] PHP Notice: Undefined variable: HTTP_POST_VARS in /srv/www/htdocs/opt/include/general.php on line 1012
[client 172.22.124.112] PHP Warning: extract() [<a href='function.extract'>function.extract</a>]: First argument should be an array in /srv/www/htdocs/opt/include/general.php on line 1012
[client 172.22.124.112] PHP Notice: Undefined variable: HTTP_SERVER_VARS in /srv/www/htdocs/opt/include/general.php on line 1013
[client 172.22.124.112] PHP Warning: extract() [<a href='function.extract'>function.extract</a>]: First argument should be an array in /srv/www/htdocs/opt/include/general.php on line 1013
[client 172.22.124.112] PHP Notice: Undefined variable: pf in /srv/www/htdocs/opt/include/gui.php on line 35
[client 172.22.124.112] PHP Notice: Undefined variable: sid in /srv/www/htdocs/opt/include/phplib/session.inc on line 397

Any help???

Discussion

  • clemens walch

    clemens walch - 2006-12-06

    Logged In: YES
    user_id=677499
    Originator: YES

    PHP problems solved but now:

    File does not exist: /srv/www/htdocs/opt/main_menu/

    Why that

     
  • Martin Vernooij

    Martin Vernooij - 2006-12-30

    Logged In: YES
    user_id=608879
    Originator: NO

    Maybe a bit late, but I'll answer anyway. OPT has not been tested/migrated to PHP5.
    You have the option to either run PHP4 & PHP5 on the same server or downgrade to PHP4. As to your second problem "File does not exist", You must have deleted something or made a typo in a rewrite?

    And looking at my personal time and priorities, no: migrating OPT to PHP5 is not on my schedule. I can't speak though for the other developers on this project.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks