Installation won't work

  • Douglas Pearless

    I have just performed a vanilla Fedora Core 4 installation, and downloaded Outreach.

    I have followed all of the instructions, and I always get:

    "Failed: You missed some fields. Please go back and try again" after I have entered all of the information on the setup webpage.

    Is there any way of determining what is causing this message.

    Note: I do not have a mail server installed, I want to be able to use my mail server on another machine, I do have Apache and MySQL and I followed the instructions for setting up the access to MySQL per the setup screen.

    I am a little bit lost, HELP!

    Cheers Douglas.

    • Paul Gillingwater

      Hi Douglas,

      I can tell you that there is a new version due to be released in the next couple of weeks, with some significant patches.  We will try to ensure it is tested against a vanilla FC4 (although I personally prefer chocolate rather than vanilla.)

      Note as a company, we can also provide commercial support, including installation assistance.  See
      Paul Gillingwater
      CSO Lanifex GmbH

      • Martin Vernooij

        Martin Vernooij - 2006-03-09


        I do believe there are more companies able to provide commercial support. I do not want this forum to be a place to advertise ourselves. We should keep the help list on SourceForge as a community forum, where users can freely ask their questions and hopefully get an answer from either one of the developers or another user. We shouldn't try to commercialize this list.

        Do you agree?


    • Martin Vernooij

      Martin Vernooij - 2006-03-09

      Still looks like you missed something in the setup page. The upcomming changes will not impact the setup page, so maybe you specified an existing DB, whilst there's none?

      Though I think FC4 has MySQL 4 or 5, so you should be waiting on the update anyway. Current version 1.2.6 only worki on MySQL 3.

      I'm working on MySQL 5.1, PHP 4.4.2 on Debian Etch, and I'll test the new version on the demo site, which is running on Redhat ES3 with MySQL 4 and PHP 4.4.2. I don't have other platforms, but I'm sure someone will want to test it.


    • hobbss2

      hobbss2 - 2007-01-05

      I get the same thing, and I know exactly what the problem is - there appears to be no code in the whole of opt to read the post variables from the form and put them into the php variables used by the setup.php code.

      i.e. setup.php is doing this:

        if (!($CRM_email && $CRM_path && $CRM_db_host && $CRM_db_db &&
        $CRM_db_uname && $temp_CRM_dir &&
        (($CRM_may_demo && $CRM_db_demo_db) || (!$CRM_may_demo)))) {
          echo("<h4><b>Failed</b>: You missed some fields. Please go back and try again.</h4>");

      but the variables $CRM_email are never being set so are all empty. Now CRM_email for example is the name of the form text input box. but I can see no code in the opt distro which does something like:
        $CRM_email = $HTTP_POST_VARS('CRM_email');

      Of course HTTP_POST_VARS is deprecated, and doesnt work as a super global in PHP 5 anyway ($_POST should be used).

      I added the following line before the if statement:

      echo "<br>SWH: $CRM_DB_uname , $CRM_email , $CRM_path<br>";

      which just produces

      SWH: , ,

      even though all the form fields are filled out.

      I can only conclude that either:
      1) the distribution is broken,
      2) setup has never worked and everyone does the install by editing config files manually
      3) it relies on some trick which works with old PHP versions but not with PHP 5 (I only know php 5).

      If its the latter case then why hasnt anyone fixed it?  I could do it but its going to take time to go through the whole source code for opt.

      • Martin Vernooij

        Martin Vernooij - 2007-01-05

        You hit the nail. OPT was develeped on php3, it has been upgrade to php4 and no one has taken on the task (yet) to make is work for php5.  Also, one requirement is staten in the install docs, which seems to have been missed here: register_globals needs to be on. As I said in other threads, I don't have OPT on my personal priority list, so if you're willing to step in, I'm sure you're more than welcome.


Log in to post a comment.