Icecast authentication issues

Zinger
2003-08-01
2004-09-19
  • Zinger

    Zinger - 2003-08-01

    I have icecast successfully working with ices, but when I try to get otto to connect, I get this error message:

    INFO connection/_handle_source_request Source (/) attempted to login with invalid or missing password

    I was thinking it might have something to do with authentication type, any ideas?

     
    • nunyo dambidness

      I'd like to see an answer to this as well.  I have the same issue with my installation.

       
    • Heino Walther

      Heino Walther - 2004-04-09

      I also get this error, I even tries with the shoutcast server, which also doesn't work...

      Have anyonw solved this one yet ?

       
    • lka

      lka - 2004-07-29

      Hi,
      I've solved this problem with a change in /usr/local/otto/lib/Otto/Shout.pm:

      .....
      sub new
      # conf
      {
          my $type = shift;
          my %p = @_;

          print STDERR "Otto::Shout->new\n" if $p{conf}->debug;

          my $self = {};

      #    my $connection = Shout->new
      #       (ip          => $p{conf}->IcecastHost,
      #        port        => $p{conf}->IcecastPort,
      #        mount       => $p{conf}->IcecastMountPoint,
      #        password    => $p{conf}->IcecastPassword,
      #        name        => $p{conf}->ShortName,
      #        description => $p{conf}->Description,
      #        url         => $p{conf}->IcecastURL,
      #        bitrate     => $p{conf}->IcecastKbps,
      #        icy_compat  => 0,
      #        ispublic    => 0) || die;
        my $connection = new Shout;

        # setup all the params
        $connection->host($p{conf}->IcecastHost);
        $connection->port($p{conf}->IcecastPort);
        $connection->mount($p{conf}->IcecastMountPoint);
        $connection->password($p{conf}->IcecastPassword);
        $connection->public(0);
        $connection->format(SHOUT_FORMAT_MP3);
        $connection->protocol(SHOUT_PROTOCOL_HTTP);
        $connection->set_audio_info(SHOUT_AI_BITRATE => $p{conf}->IcecastKbps, SHOUT_AI_SAMPLERATE => 44100);
        $connection->description($p{conf}->Description);
        $connection->name($p{conf}->ShortName);

          $connection->genre($p{conf}->IcecastGenre) if $p{conf}->IcecastGenre;
      .....

      best regards
      Lka

       
      • WOLfgang Schricker

        Hello from Bamberg, Germany,
        my 'channel_1.log' shows this line
        ---8<-----8<---
        No such Shout constant 'SHOUT_FORMAT_MP3' at /opt/otto/lib/Otto/Shout.pm line 62
        ---8<-----8<---

        Can you help my?

         
      • Stefan Schlörholz

        Hello,

        I have the same problem with the failed login.

        I tried your uggestion of changes to the Shout.pm. Here's my output after "otto start":

        computer # Global symbol "$connection" requires explicitpackage name at /usr/local/otto/lib/Otto/Shout.pm line 49.
        Compilation failed in require at /usr/local/otto/lib/Otto/Jockey.pm line 71.

        Thanks for your help

         
    • Rick Parker

      Rick Parker - 2004-08-20

      Thanks Lka, this worked for me.
      At first tried it, and it didn't, then realized I didn't have thread enable in perl so libshout was messed up.  I recompiled libshout without threads and then your changes worked for me.

       
    • Stefan Schlörholz

      Hello,

      I have issues with icecast therefor I am interested in the scripts.

      How did you manage to get icecast working with mp3 files. I get login failures from otto.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks