"Couldn't connect"

Paul
2004-07-07
2013-03-22
  • Paul

    Paul - 2004-07-07

    What am I doing wrong? Icecast (1.3.12-debian) works smoothly to stream static files. Otto seems happy with the libraries and modules I gave it: Shout 2.0.1 and libshout 2.0. Test mode works great. But when I launch Otto using a shout channel, I get the following in the debug log:

    new DB dbname='otto'
    Otto::Shout->new
    Couldn't connect at /usr/local/otto/lib/Otto/Shout.pm line 68.

     
    • art

      art - 2004-08-29

      I have exactly the same problem. Test mode is OK, Mpg123 output works OK, but shout channel gives:

      new DB dbname='otto'
      Otto::Shout->new
      Couldn't connect at /usr/local/otto/lib/Otto/Shout.pm line 68.
      Has anyone got any ideas please?

       
    • Rick Parker

      Rick Parker - 2004-09-04

      Are there any hints in your icecast log files?
      I think when I first installed I found authentication issues in my icecast log and the same error you're getting in my otto log.

       
    • Stefan Schlörholz

      Hello,

      I have the exact same problem. Did you get a solution for that already?

      My icecast access.log shows:
      127.0.0.1 - - [19/Sep/2004:23:00:48 +0200] "SOURCE / ICY/666" 401 115 "-" "-" 0

      Whatever that means.

      Password in otto.conf and icecast.xml are the same.

      I am happy for any help.

       
    • attilla

      attilla - 2004-09-24

      Try removing line 41  (icy_compat => 0) from Shout.pm in /usr/local/otto/lib/Otto. It worked for me
      good luck

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks