OTA installation

Help
2013-06-03
2016-06-13
<< < 1 2 (Page 2 of 2)
  • e-Novate

    e-Novate - 2014-01-19

    Hi Dave,

    The OTA Hotel Management software is standalone, it does not require e-Bridge registration to use it. The message you are reporting sounds as though you have a problem with your DNS configuration on your computer.

    The only reason to register with e-Bridge is to get access to extra features, website or online booking engine, advanced customer profile features.

    We try to keep track of who installs our software, as we have found that there are a few companies that are downloading our software then reselling it as their own software and not honoring the GPL.

     
  • Dave Trotter

    Dave Trotter - 2014-01-20

    Thanks for that - in that case I will continue to try to get this going. Situation now is if I open localhost/hotelmis it takes me to the starting configuration screen again. I complete all the data fields for the hotel and save, I then go to the room configuration again. Complete one of those again and I am taken online to the login page of e-novate bridge and asked to login. Although I registered already I still don't have a login username or pwd so I am unable to go any farther. Now, looking at the hotelmis database I find I not only have no data but have no tables either so need to ask again if my importing hotelmis.sql in the installation phase was all that the setup required or did I get this stage wrong?

     
  • Dave Trotter

    Dave Trotter - 2014-01-20

    Just ran the hotelmis.sql again having deleted previous user and I now see the hotel data recorded in the database. Still get to the e-bridge login screen though and no farther without a username and pwd. Is this where I should be - am I waiting for a username email from you and this is the normal startup operation for this software?

     
    • e-Novate

      e-Novate - 2014-01-20

      Hi,

      There is no account information required from us to use the software. The setup will relaunch if it detects any default information from e-Novate in the system configuration.
      So re-running the hotelmis.sql you re-instated the defaults.
      Please have a look at our Youtube video, while it is for windows the configuration component is the same.

       
      • e-Novate

        e-Novate - 2014-01-20

        Hi,

        The default account is "admin"/"password"

        To further expand, the defaults settings that are testing for are a valid email address, company name, street, email, company and registration.
        If any of these are set, then the configuration page will launch.

        Also at the bottom of the page is a Help link. You should press this to get more information about how to read it..

        Thanks

         
  • Dave Trotter

    Dave Trotter - 2014-01-20

    Thank you - the default username/password solved it. That was obviously the problem from the beginning...........

     
  • Dave Trotter

    Dave Trotter - 2014-02-15

    Okay, have the software up and running now on Mint 16. Two things I need help with though;
    a) The reports page is blank except for the headers - have checked that the user has access to reports in the user creation module - ticked every box in fact. But still a blank page....
    b) Given that our accommodation falls into four different categories in respect of size and type, we really must to be able to see an overview of available accommodation for a particular date when we receive a booking query. I can't see any way at present to look at accommodation on a set date.
    Any help you can offer will be much appreciated, we'd really like to get this into operation asap.
    Dave

     
    • e-Novate

      e-Novate - 2014-02-17

      Hi Dave,

      Not every feature is available in the opensource, as some of the APIs needed are closed source and not GPL. So we cannot publish everything.
      The 2nd feature you are asking for is not currently available at the moment, but we will see about putting it on the work stack.

       
  • Makis Tzakis

    Makis Tzakis - 2014-02-27

    Hello,
    I am trying to install it in a live server, when i am setting up my hotel i receive this message
    arning: Cannot modify header information - headers already sent by (output started at /public_html/book-online/validate_email.php:254) in //public_html/book-online/setup/configsetup.php on line 98

    Can i do something for that? so to continue the installation?

    Thanks in advance

     
    • e-Novate

      e-Novate - 2014-02-27

      Hi,
      I am going to assume live means public linux host either VPS or dedicated.
      If this is the case, the following is a warning for usage.
      1. OTA Hotel is a PMS - not a B2C online booking engine, it is designed for inside a secured LAN, as the database is NOT encrypted.
      2. Online components are only available with the e-Bridge plugin which is not opensource and requires payment.

      Please note we will not offer any help to make this a cloud based solution, as it is not designed to be one. As you cannot checkin/out guests in a hotel if your internet goes out and infrastructure can be unstable and internet can be extremely expensive in some countries.

      Your problem.
      1. hotelmis is the default directory, and a lot of places are set to look for this
      2. hotelmis directory needs to be owned rw by the apache user.
      3. php5-curl needs to be installed also.

      hope this helps

       
  • JAF

    JAF - 2015-06-26

    I am not able to set this OTA Hotelmis properly I am only getting your URL https://www.e-bridgedirect.com what is the ptoblem Please help me solve this

     
  • JAF

    JAF - 2015-06-26

    I was able to enter and save the basic hotel data page, and then the room information. The program then took me off to the enovate registration site. I have no wish to sign up there as yet and possibly not at all, not sure yet. Is it not possible to use this program without an account with your company? Registered anyway, just in case - now I'm stuck on a white page at e-bridgedirect.com/registrationweb/register.php. Status is 'waiting for www.e-bridgedirect.com'

     
    • e-Novate

      e-Novate - 2015-06-26

      Please check out our youtube channel e-novate.asia

      There is no need to register to use the free version. That is only to register for the evaluation and purchase of the OTA directory reporting and advanced features.

      If you have done a standard install to a default location.

      http://localhost/hotelmis

      Please JAF, in future try to reply in the same discussion forum that you have started the question in. This is quite confusing for other people that follow support.

       
  • SSDC

    SSDC - 2015-08-22

    Hi
    I have Installed WAMPS and OTA software as you showed in video above but when its going for final confugration that time its says HTTP 404 Not Found i.e. I am not able to install this application.

    Can you please help me in this ?

     
    • e-Novate

      e-Novate - 2015-08-22

      Hi,

      Unfortunately you have not given a lot of information to assist you with.
      You note you have installed WAMP, what version of windows?
      Have you established your WAMP is correctly installed?

      What url is showing 404 not found?
      Which version of OTA Hotel did you install?
      Do you get the basic apache page?

       
  • SSDC

    SSDC - 2015-08-22

    I have Installed WAMP with windows 7
    WAMP correctly installed = Sorry I dont know much about it but I did as per your above youtube video.

    http://localhost/hotelmis = this is the url

    Latest i.e. 2.0.1472

    I dont know how to get the basic apache page.

    Sorry for limited knowledge of the server.

     
    • e-Novate

      e-Novate - 2015-08-23

      Ok, the basic apache page is http://localhost
      It should show you a default installation page.

      If that works ok, test your PHP is installed correctly.

      In the htdocs directory of your WAMP.
      If you have followed the instructions directly from the Youtube video, then the directory should be
      C:\WAMP\Apache Software Foundation\Apache2.2\htdocs
      Create a file called test.php

      then open http://localhost/test.php
      It should show you a diagnostics page.

      If you get here, then your PHP and Apache is installed correctly.
      Then check if you MySQL - mysqld is installed correctly.
      go to the command prompt
      cd c:\WAMP\MySQL\bin

      type
      mysql -u root -p
      Enter password: ****

      mysql> mysqlshow databases;
      you will see a list of tables

      one of these should be hotelmis.

       
  • Harvey Y Speed

    Harvey Y Speed - 2016-06-12

    Hi,

    I am using Debian to test out OTA Hotel Management.

    I downloaded otahotel_2_3_1725.zip but I was unable to unzip it.

    I then downloaded otahotel_2_2_1625.zip and I had no problems unzipping it.

    I thought I should mention this so that others may be aware.

    Thank you

     
  • Harvey Y Speed

    Harvey Y Speed - 2016-06-12

    Hi,

    I am trying to install OTA on Debian.

    Apache is installed and working. I don't know if I need additional modules.

    MySQL is installed and working. I don't know if I need additional modules.

    PHP is installed and working. I don't know if I need additional modules.

    I have unzipped otahotel_2_2_1625.zip into /var/www/hotelmis. The default permissions for that directory are rwxr-xr-x.

    In /var/ww/hotelmis, I ran the command :

    mysql --user=root --password={mypassword} <hotelmis.sql

    I got the following error :(

    ERROR 1136 (21S01) at line 1092: Column count doesn't match value count at row 24"

    I looked inside mysql with "use hotelmis=>show tables" and I have 60(?) tables created.

    I also had user "hotelmis" created.

    I looked at hotelmis.sql with a text editor and noticed that line 1092 seems to contain data for 'housekeeping' :-

    / Date for house keeping /
    insert into housekeeping (itemID, productID, shortName, description, productCode, cost, charge, tax, service, taxAmnt, svcAmnt, image, active).....

    I assumed that being data, I could get away with it by trying to run OTA anyway.

    So, I entered "http;//localhost/hotelmis" into my browser.

    Unfortunately, all I got was the php script for /var/www/index.html displayed in the browser. :(

    Using "netstat -tlpn | grep mysql" shows that mysql is listening down port 3306, so I did not have to change configuration.inc.php.

    I would appreciate any help to help me get this running.

    Thank you.

     
    • e-Novate

      e-Novate - 2016-06-13

      Hi,

      Thanks for letting us know about the busted zip file, we will fix it.

      For your SQL, yes you are correct, an it should be ok, but just check and make sure the last bits of data after line 1092 are run.
      It should be the version number SQL. You can just run the remaining couple of lines manually.

      If your apache is just displaying the php script, then it probably does not have the php setup in your LAMP setup.

      The simple way to test is create a file called

      /var/www/test.php

      in the file add the contents

      the open your web browser to http://<host>/test.php

      You should see all of the PHP settings, but if you see the script, then your Apache is not configured for PHP

      There are lots of sites that already explain how to fix this, so I will just drop a link.

      http://unix.stackexchange.com/questions/8604/getting-php-to-work-with-apache-to-run-php-files-through-browser

      But if you see all of the PHP info, then you should be able to get to the login screen
      If you get another error please attach it to your response.

      Regards

       
<< < 1 2 (Page 2 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks