Not working on 10.6.3

  • Micah Leier

    Micah Leier - 2010-04-20

    When I connect my USB-serial device everything works fine, the device is created in /dev and everything. When I try to read from it however I get these messages in dmesg:

    nl_bjaelectronics_driver_PL2303(0xe163c00)::allocateResources failed - no fpInPipe.
    nl_bjaelectronics_driver_PL2303(0xe163c00)::start Allocate resources failed
    nl_bjaelectronics_driver_PL2303(0xe163c00)::CheckSerialState - StartSerial failed

    Any ideas as to whats causing this?

  • woo oow

    woo oow - 2010-04-20

    check this:
    maybe it'll help. I never used it, so if you, please post your experience here


  • Micah Leier

    Micah Leier - 2010-04-20

    I've determined that the device is bad I'm pretty sure. The windows driver wont work with it on vista, on xp it appears fine but throws random errors when used and on linux it doesn't throw any errors but doesn't actually create the serial device. I've ordered another off of amazon. Thanks for the help though.

  • Anonymous

    Anonymous - 2010-05-05

    I tried the same thing and found that there is no device added inside /dev/

    What could be going wrong here? How do I know the driver is properly installed?


  • Micah Leier

    Micah Leier - 2010-05-05

    As I said above, for me at least it was a problem with a bad device, it wouldn't work on any other computer/os. Have you tried yours on a few different computers/OSes?


Log in to post a comment.