#7 osslsigncode >= 1.5 requires openssl 1.0

v1.0_(example)
closed-fixed
nobody
None
5
2014-02-26
2014-01-24
Thanh Ha
No

While the configure script says you require openssl 0.9.8 or newer. The code actually requires openssl 1.0 or greater due to a changed state:

https://www.openssl.org/docs/crypto/ERR_remove_state.html

Would it be possible to patch it to add support for openssl 0.9.8 and 1.0?

I need to be able to build osslsigncode 1.6 this with openssl 0.9.8.

Build log:

make all-am
make[1]: Entering directory /home/data/users/tha/osslsigncode-1.5.2' gcc -g -O2 -o osslsigncode osslsigncode.o -lcrypto -ldl -lz -lcurl osslsigncode.o: In functioncleanup_lib_state':
/home/data/users/tha/osslsigncode-1.5.2/osslsigncode.c:680: undefined reference to ERR_remove_thread_state' collect2: ld returned 1 exit status make[1]: *** [osslsigncode] Error 1 make[1]: Leaving directory/home/data/users/tha/osslsigncode-1.5.2'
make: *** [all] Error 2

Discussion

  • Per Allansson

    Per Allansson - 2014-01-24
    • status: open --> closed-fixed
     
  • Per Allansson

    Per Allansson - 2014-01-24

    Yes, thanks. Fixed in trunk.

     
  • Thanh Ha

    Thanh Ha - 2014-01-24

    Thanks for the quick fix!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks