#72 Osmo fails to build from source because of outdated Makefile.am

v1.0 (example)
closed-fixed
nobody
None
5
2014-09-13
2013-06-22
No

Osmo fails to build from source because the build system cannot be recreated without error messages. The version of automake is 1.13.3.

automake: warnings are treated as errors
po/Makefile.am:2: warning: wildcard ../src/.c ../src/.h: non-POSIX variable name
po/Makefile.am:2: (probably a GNU make extension)
po/Makefile.am:21: warning: '%'-style pattern rules are a GNU make extension
po/Makefile.am:24: warning: '%'-style pattern rules are a GNU make extension
src/Makefile.am:1: warning: ':='-style assignments are not portable
src/Makefile.am:1: warning: shell if test -e .svn; then echo -DREV=\"LC_ALL=C svn info | sed -n '/^Rev/p'| sed -e 's/^Revision:\ //'\"; fi;: non-POSIX variable name
src/Makefile.am:1: (probably a GNU make extension)
src/Makefile.am: installing './depcomp'
src/Makefile.am:62: warning: 'CFLAGS' is a user variable, you should not override it;
src/Makefile.am:62: use 'AM_CFLAGS' instead
autoreconf: automake failed with exit status: 1
dh_autoreconf: autoreconf -f -i returned exit code 1

As a temporary fix i have disabled -Werror for AM_INIT_AUTOMAKE in configure.ac

1 Attachments

Discussion

  • Tomek

    Tomek - 2014-09-13
    • status: open --> closed-fixed
     
  • Tomek

    Tomek - 2014-09-13

    Thanks!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks