install not finding libgcc or libncurses

2011-03-10
2013-05-01
  • john skelton

    john skelton - 2011-03-10

    Hi,
    Am trying to install osmius on a fedora 11 x64 server. It is not finding these files because they are in /lib64/, any ideas on how to fix this?

     
  • john skelton

    john skelton - 2011-03-10

    I have tried adding /lib64 to my PATH, still no joy, tried adding /lib64/libgcc_s.so.1 to path but failed to find the file, which turns out to be  a link to libgcc_s-4.4.1-20090729.so.1

     
  • jlmarina

    jlmarina - 2011-03-11

    Hi there,

    Thanks for choosing Osmius.

    You need to install 32 bit support libraries into your 64 box.
    The community version of Osmius comes only in 32 bits and works smoothly and with very good performance.
    In other Linux flavours (Ubuntu, Suse,…) the 32bits compatibilty is very easy to install but Fedora is more tricky.
    Take a look here:
      http://www.osnews.com/story/22116/Installing_32bit_Support_Into_64bit_Fedora

    Hope this helps.

      Osmius Support Team

     
  • Manuel Fraga

    Manuel Fraga - 2011-03-23

    My experience with 64-bit Linux RedHat.

    List of packages that we had to install:

    32-bit libraries:
       - glibc
       - libgcc
       - ncurses

    64-bit libraries:
       - libstdc++.so.6
       - libcom_err.so.2 -> e2fsprogrs
       - device-mapper
       - libselinux
       - libsepol

    After this everything went fine.

    Please, let us know if it works for you.

     
  • john skelton

    john skelton - 2011-03-30

    Adding the x32 libs and ncurses worked like a champ, thanks for the information and help, now I just have to figure out how to use it :)
    John

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks