Problem installing the OpenSceneGraph Max Exp

  • bezadesign

    bezadesign - 2011-07-04

    Please help me
    After installing the OpenSceneGraph Max Exporter (all went well…I install the files in C:\Program Files\OSGExp)
    I tried open 3dmax9 and I received a c++ error runtime
    I attached the errors i received

    Can somebody tell me what i am doing wrong?
    Do i need to compile the code?
    Do i need to install OpenSceneGraph un my computer first @&#$@ :)
    Thanks in advance

  • bezadesign

    bezadesign - 2011-07-06

    Everything is working fine now
    You did a wonderful work with this exporter :)

  • fran

    fran - 2011-07-23

    I am having the same problem.
    Any solution?
    Thanx in advance

  • edwin rustia

    edwin rustia - 2011-08-27

    need help please!
    im also having the same problem.

  • Cooper Hawkes

    Cooper Hawkes - 2011-09-09

    I'm having the very same problem with 3DS Max 2009.
    I assume that there is some redistributable from MS missing.

    Did anyone find a solution so far?
    @bezadesign: Could you share your solution with us?

    Thanks & BRgs

  • Cooper Hawkes

    Cooper Hawkes - 2011-09-09

    Here is what I found so far:
    OsgExp version 0.9.8 works… :)
    versions 0.9.9 and 1.0.0 do NOT work… :(
    (tested on WinXP 32 bit, 3ds Max 2009, all .Net redistributables that I know of installed)

    Nonetheless, I'd be interested in getting version 1.0.0 to work… :-/
    Any hints?

  • Cooper Hawkes

    Cooper Hawkes - 2011-09-12

    I've (re-)installed the VC 2008 runtimes… no luck though. Then I've reinstalled the SP1 for these runtimes
    (see here: ) … still no luck.

    I've found that OsgExp seems to install its own versions of msv*90.dll into the 3ds Max folder. Maybe there is something going wrong with the manifest dependencies.
    VC 2008 still uses the global assembly cache and you really have to be careful about the right dependencies in the assembly manifests… Adding your own version of the runtimes isn't the best idea, because dependencies might change with security updates.
    M$ learned from their error and VC 2010 switched back to the old style of just throwing all the runtime DLLs into "windows\system*" folder… no more assembly manifests, no more trouble… ;)

    I hope that there is some time left this week so that I can try to find the culprit with dependency walker…

  • Farshid Lashkari

    I might have found the cause of this problem. I've rebuilt the installers and will send you a download link so you can test it out.

  • Cooper Hawkes

    Cooper Hawkes - 2011-09-13

    Thanks for sending me the new installers. Unfortunately I have only WinXP 32 bit on my machine, therefore I could test only the 32bit version (with 3ds Max 2009)… aaaaaand it works! :)
    Thanks a lot for your efforts! Much appreciated!

    I've played around with the export options… I like the new interface… :)

    Unfortunately I found another issue: If you enable Optimize -> Tri Strip Geometry, then the export crashes while "Optimizing scenegraph…". Export works like a charm though as long as you don't use optimization.
    I've attached the callstack for the sake of completeness… however, this crash might be some sort of problem within OSG itself and not OsgExp. Maybe I do some more tests and open a new bug-report later…

     # ChildEBP RetAddr  Args to Child
    00 0013c6ac 7e419418 7e42770a 004a0bca 00000001 ntdll!KiFastSystemCallRet (FPO: [0,0,0])
    01 0013c6e4 7e4249c4 004c0b48 004a0bca 00000001 USER32!NtUserWaitMessage+0xc
    02 0013c70c 7e43a956 7e410000 19776008 004a0bca USER32!InternalDialogBox+0xd0 (FPO: [Non-Fpo])
    03 0013c9cc 7e43a2bc 0013cb28 00000000 ffffffff USER32!SoftModalMessageBox+0x938 (FPO: [Non-Fpo])
    04 0013cb1c 7e4663fd 0013cb28 00000028 004a0bca USER32!MessageBoxWorker+0x2ba (FPO: [Non-Fpo])
    05 0013cb74 7e4664a2 004a0bca 0019aeb8 001aff28 USER32!MessageBoxTimeoutW+0x7a (FPO: [Non-Fpo])
    06 0013cba8 7e450877 004a0bca 1e6bb2a0 1e6bb730 USER32!MessageBoxTimeoutA+0x9c (FPO: [Non-Fpo])
    07 0013cbc8 7e45082f 004a0bca 1e6bb2a0 1e6bb730 USER32!MessageBoxExA+0x1b (FPO: [Non-Fpo])
    08 0013cbe4 00405f25 004a0bca 1e6bb2a0 1e6bb730 USER32!MessageBoxA+0x45 (FPO: [Non-Fpo])
    WARNING: Stack unwind information not available. Following frames may be wrong.
    09 0013cc34 004f72a0 00400000 0000eb26 0000eb27 3dsmax!EnableUndoMenu+0x2965
    0a 0013cc68 004f97a8 00000000 0013cff0 004fa3a0 3dsmax!XMLAnimTreeEntry::GetMapUnique+0x79970
    0b 0013cd14 004fa3c4 0013cff0 7c885780 7c864191 3dsmax!XMLAnimTreeEntry::GetMapUnique+0x7be78
    0c 0013cf90 7858cc2c 0013cff0 1442a930 c0000417 3dsmax!XMLAnimTreeEntry::GetMapUnique+0x7ca94
    0d 0013d2c8 7858ccd5 00000000 00000000 00000000 MSVCR90!_invoke_watson+0xf9 (FPO: [Non-Fpo])
    0e 0013d2e0 12f21a0d 14461f8c 1444ffe8 0013d420 MSVCR90!_invalid_parameter_noinfo+0xc (FPO: [0,0,0])
    0f 0013d4a8 7857e0e3 14483920 14461e20 1445fa00 osg73_osgUtil!osgUtil::TriStripVisitor::apply+0x6ed
    10 0013d550 12c19c5f 00000000 00000000 00000000 MSVCR90!__RTtypeid+0x102 (FPO: [Non-Fpo])
    11 0013d578 12c19c5f 00000000 00000000 00000000 osg73_osg!osg::Group::traverse+0x6f
    12 0013d5ac 12f24a28 14436150 0013dbc0 1442dd58 osg73_osg!osg::Group::traverse+0x6f
    13 0013d5cc 12ede0d9 3562d719 00000400 1e6b8240 osg73_osgUtil!osgUtil::TriStripVisitor::stripify+0x58
    14 0013d5f4 747313d9 7e42b372 00000000 00000001 osg73_osgUtil!osgUtil::Optimizer::optimize+0xa99
    15 0013d65c 63d1fdc7 ffffffff 7e418734 001e104c MSCTF!SysGetMsgProc+0x7e (FPO: [Non-Fpo])
    16 0013d78c 7e418734 001e104c 0013d7cc 12a40000 core!NodeAndAnims::ReleaseInterface+0x44f7
    17 0013d79c 7c910222 14448c20 00000000 1444b678 USER32!InternalCallWinProc+0x28
    18 0013d7cc 7c91019b 7c9101db 00000400 00000018 ntdll!RtlpAllocateFromHeapLookaside+0x42 (FPO: [Non-Fpo])
    19 0013d9f8 78583db8 12a40000 00000000 00000018 ntdll!RtlAllocateHeap+0x1c2 (FPO: [Non-Fpo])
    1a 0013da18 78583eb8 00000018 00000004 7e42a340 MSVCR90!malloc+0x79 (FPO: [Non-Fpo])
    1b 0013da30 12f16237 00000018 12ecaf0d 3562d885 MSVCR90!operator new+0x1f (FPO: [Non-Fpo])
    1c 0013da38 12ecaf0d 3562d885 0013dbc0 0013dbc8 osg73_osgUtil!osgUtil::Tessellator::endTessellation+0x87
    1d 0013da54 12eaf42b 0013da6f 0013da6f 3562d8a9 osg73_osgUtil!osgUtil::Optimizer::FlattenStaticTransformsDuplicatingSharedSubgraphsVisitor::transformGeode+0x6cd
    1e 00000000 00000000 00000000 00000000 00000000 osg73_osgUtil!osgUtil::Optimizer::Optimizer+0x4b
  • Farshid Lashkari

    Glad to hear the installer is working! Thanks for testing it out for me.

    Regarding the Tri-Strip crash, other users have reported this before. Does the model contain a lot of vertices? You might be running out of memory. Try exporting without the optimizations and running the tri-strip optimization on the file using the osgviewer application.

  • Cooper Hawkes

    Cooper Hawkes - 2011-09-14

    The model contains only a few hundred vertices (about 700).
    Actually it's not such a big deal for me (especially since only 700 vertices don't really need to be tri-stripped)… I just found it while playing around with the settings.
    I'll have a look though if "manual" tri-stripping in the osgviewer works.


Log in to post a comment.