#772 update-rpms picks wrong version

4.2.1 (deprecated)
closed
9
2006-03-21
2006-01-12
Erich Focht
No

When building an image on a SL4 master where
the /tftpboot/rpm directory contains old and new SL
rpms, update-rpms chooses to install
kernel-2.6.9-22.EL
instead of the newer version:
kernel-2.6.9-22.0.1.EL

I localised the bug in the numeric version comparison
routine. I consider this a serious bug because we
rely on update-rpms choosing the newer rpms. It
should be fixed for 4.2.1!

Discussion

  • Erich Focht

    Erich Focht - 2006-01-12
    • priority: 5 --> 8
    • assigned_to: nobody --> efocht
     
  • Erich Focht

    Erich Focht - 2006-01-12

    Logged In: YES
    user_id=338721

    David, do you agree to the patch which I attached?
    I tentatively changed the version to 1.1.23-1 but
    don't know whether this follows your revision rules.

    Passing this bug to you.

     
  • Erich Focht

    Erich Focht - 2006-01-12
    • assigned_to: efocht --> dnl
     
  • Erich Focht

    Erich Focht - 2006-01-12

    update-rpms.diff

     
  • John

    John - 2006-01-24
    • priority: 8 --> 9
     
  • John

    John - 2006-01-24

    Logged In: YES
    user_id=505737

    bumped as per call

     
  • Bernard Li

    Bernard Li - 2006-03-21
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks