Where is the Primer?

  • JO3Y

    JO3Y - 2007-08-27

    Hi all, glad to find you here, glad to be here. after more than a week chasing down so many old and inactive ORM sites about old tools requiring old microsoft product versions, i'm *thrilled* to find this active project.

    i have NORMA installed and even have a diagram. but i really need instructions on how this should be used. I've read the ORM primers - i need the NORMA primer. the learning curve is painful. i'd like to start entering entities, roles, and constraints with text, rapid fire, for example.

    can someone point me in the right direction?



    • Kevin M. Owen

      Kevin M. Owen - 2007-08-27

      Hi Joe, welcome to the community :-)

      To start off with, I would recommend trying some of the walkthrough labs available from our "Documentation" release at https://sourceforge.net/project/showfiles.php?group_id=158881&package_id=178202&release_id=409661.

      In addition, if you have any questions, we would be happy to answer them.


    • JO3Y

      JO3Y - 2007-08-28

      Thanks. The Lab ppt's are really nice.

      I have a minor question about pg 20 of lab1, which reads in the notes:

      The toolbox gesture for this is:
      1)Select Internal Uniqueness Constraint
      2)Click the fact to add it to. The constraint will be added activated with no constraints.
      3)Click the first role
      4)Double click the second role to add it and commit the constraint

      I tried this but could not exactly figure out what (2) really means. everything I tried resulted in no noticable change. Any idea what I'm doing wrong? I think a reference to the pane in which this should be done would help.

      Of course the primary method in the slide is fine, but there might be a reason for someone to prefer the toolbox gesture.



    • JO3Y

      JO3Y - 2007-08-28

      On slide 34 of Lab1, the third step does not happen as described. Perhaps I did not understand what the "document tab" is, or the slide has become outdated. What did work is:

      Instead of step 3: After completing step 2, a Relational View button is automatically created. Simply clicking this shows the relational view page.

      I am collecting my notes on this experience (from a newbie perspective) so that I can help update this lab after my suggestions are confirmed. When I have thoroughly documented these issues, I will send an updated slide later for review.

    • JO3Y

      JO3Y - 2007-08-28

      In particular, there is a rather serious pitfall on slide 7, which I have annotated as follows:

      *Note: when entering a fact type in the fact editor, do not type an intervening space between object and identifier type in the fact

      Patient(nr) has PatientName()

      Entering a space between entity type 'Patient' and identifier '(nr)' causes the identifier to be interpreted, and become,  part of the predicate. If this error is edited afterwards, do not attempt to edit the entity name in the diagram; this will cause (nr) to become part of its name. Instead, edit the Ref Mode property to 'nr' in the properties window. Be sure also to remove (nr) from the predicate’s ReadingText property in the properties window.

      Similarly, if you enter an intervening space in 'PatientName ()' the () becomes a second predicate n-fix:
      ... (nr) has ... ()

      and PatientName will be created as EntityType, instead of ValueType as intended. In the latter case, edit the IsValueType property to read “True” (see slide 25). The second predicate n-fix can be removed as above in the predicate's ReadingText property.

    • Andy Cordes

      Andy Cordes - 2007-08-28


          I think it may read better in the following way:

          1) Select Internal Uniqueness constraint in the Toolbox.
          2) Click the first Fact type on the drawing surface. The constraint will be displayed but grayed out because we need to specify what roles this constraint covers.
          3) Click the first role, then the next. When all the roles are covered (they turn yellow when selected), double click on the final role. When the final role is clicked, the constraint is added.

          Note that if the roles are not added, the constraint will still be shown on the diagram with error.

          Hope that helps.


    • JO3Y

      JO3Y - 2007-08-29

      Thanks, referring to slide 20 notes again:

      I'm sorry to be a pest about it. I've tried to follow this to the exact detail and no matter how I try, absolutely nothing happens.

      For clarity's sake, "the first Fact type" I understand to mean the binary fact type glyph above its reading 'is allergic to' but I don't understand why you said 'first.'

      I thought also that you might have meant 'first [role] of [the] fact type' but in any case, only this happens:

      after clicking the internal uniqueness constraint tool, mouse pointer becomes pink "..." while hovering anywhere on the drawing surface but becomes a 'forbidden' pointer icon when it is hovered over or near any entity type, value type or fact type. If i click on or near the fact type the mouse just reverts back to an ordinary pointer.

      I don't know what to think. Maybe we are using different versions or something not so obvious is wrong. But I think we are using the same terminology.

      I made a collage of screenshots but i don't see a way to attach it.


Log in to post a comment.