• Jim

    Jim - 2007-12-11

    Trying to install NORMA_VS-2007-11CTP.VS2005
    On Vista SP1 (RTM)

    Batch job starts, requests Admin control.
    Microsoft DSL is installed
    Neither Neumont PLIX nor Newmont NORMA appear to install.
    Task Manager does not appear to show any related activity.

    I uninstalled NORMA and Microsoft DSL manually prior to starting the install.

    Any clues how to get NORMA back in gear?

    • Jim

      Jim - 2007-12-11

      My apologies. I get so impatient.
      Third try appears to have worked. :)

      • Brian Nalewajek

        Brian Nalewajek - 2007-12-11


        I think the only thing the batch file does is check to make sure the PLiX and DSL Tools are up to date.  I found I need to click on the nORMa msi to get the actual install.  I haven't done the Vista SP yet, please post relevant comments on your experience with nORMa and the SP - also which edition of Vista are you using?  I've been using Vista since the summer, but only upgraded to Ultimate (so I could get this notebook in my domain), last month.

        BTW,  looks like there's a recent update to the documentation bundle (in the download section here, not the 'Documentation' section).  I don't know what material was updated, but worth a look if you get stuck.


        • Jim

          Jim - 2007-12-12

          I'm running Vista Enterprise, SP1, v.667 (not yet publicly available).
          I did get NORMA to install, and it works fine. not quite certain why I had trouble the first time.
          It appears to me that the Relationship View is smoother - but I only used it once previously.

          Now that a VS 2008 install script is available I should try that. We have VS easily available to me.

    • maria keet

      maria keet - 2008-02-07

      I'm trying to get NORMA working again after an odd Visual Studio 2005 error in version 8.0xxx, on winXP 2002, sp2 (I did the repair on the .NET framework 2.0 as suggested, and that is working again), also with the latest NORMA_VS-2007-11CTP.VS2005. removed plix, reinstalled it, removed 'Microsoft DSL Tools Redistributable' and reinstalled it. The NORMA setup even says it installed correctly (all three are installed according to the 'Add/remove' in the CP), but when I create a new project, and add a new item ORM file, even that works, but then upon opening, I neither can get the graphical interface nor the the ORM toolbox on the left-hand side become active. Instead of the pane to draw on, I get to see this:

      <?xml version="1.0" encoding="utf-8"?>
      <ormRoot:ORM2 xmlns:orm="" xmlns:ormDiagram="" xmlns:ormRoot="">
          <orm:ORMModel id="modelId" Name="emmsad08Example"/>
          <ormDiagram:ORMDiagram id="diagramId" IsCompleteView="false" Name="emmsad08Example" BaseFontName="Tahoma" BaseFontSize="0.0972222238779068">
              <ormDiagram:Subject ref="modelId"/>

      idem when I open previously created ORM diagrams (but then with a longer xml list).

      I've tried various sequences of removing, repairing, (re)installing and rebooting, but to no avail. Any suggestions?

      • Kevin M. Owen

        Kevin M. Owen - 2008-02-07

        In the Solution Explorer (which shows the files in your project and is usually on the right hand side of the screen), try right clicking on the ORM file and selecting the "View Designer" command if it is available. If it asks something like "The file is already open. Do you want to close it?", say yes.
        If that doesn't work, or if the "View Designer" command isn't available, you can try right clicking on the ORM file and selecting "Open With...". In the list that opens up, click on the entry for "ORM Designer", then click "Set as Default", and then "OK".
        Please let us know if this doesn't get it working for you or if you need any other assistance.

    • maria keet

      maria keet - 2008-02-07

      I can see the "View Designer" when right-clicking on the orm file in the Solution Explorer, and get into the design view.
      Regarding the "selecting "Open With...". In the list that opens up, click on the entry for "ORM Designer",", there is no "ORM Designer" in that list, and it asks me for an .exe if i want to add one, but there's no exe for NORMA, at least not in the Neumont directory.
      I've done another session of factory default (Vsidual Studio), repairs, removes, and reinstall (NORMA and cs.), new projects and new items. Am I forgetting to set, e.g., a checkbox so that it doesn't want to activate the ORM Designer even though it recognises it's there?

    • Matthew Curland

      Matthew Curland - 2008-02-08

      Is it possible you had a package load failure at some point and disabled the NORMA package.
      From the start menu, open a 'Visual Studio 2005 Command Prompt' window (on the 'Start\Visual Studio 2005\Visual Studio Tools' menu)
      At the command prompt, run the following two commands after NORMA is installed (the second one may take awhile):
      devenv /resetskippkgs
      devenv /setup

      devenv will now launch Visual Studio. See if your NORMA status has changed.


    • maria keet

      maria keet - 2008-02-08

      Yes! not that I have seen any package load failures, but now it works again.
      thanks :)



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks