Oratcl 4.4/Solaris SPARC 5.8 basic problem

Help
2006-05-22
2013-04-16
  • Larry W. Virden

    Larry W. Virden - 2006-05-22

    Okay, I have built a version of oratcl 4.4 . Here's the behavior I'm seeing - perhaps something new is required?

    $ /usr/tcl84/bin/tclsh
    % info patchlevel
    8.4.7
    % pwd                
    /vol/tclsrcsol/tcl84/oratcl4.4/unix
    % set auto_path [list /vol/tclsrcsol/tcl84/oratcl4.4/unix $auto_path]
    /vol/tclsrcsol/tcl84/oratcl4.4/unix {/usr/tcl84/lib/tcl8.4 /usr/tcl84/lib}
    % package require Oratcl
    can't read "env(ORACLE_HOME)": no such variable
    % exit
    gjj27awu (183) $ . casora D021
    gjj27awu (184) $ /usr/tcl84/bin/tclsh
    % info patchlevel
    8.4.7
    % set auto_path [list /vol/tclsrcsol/tcl84/oratcl4.4/unix $auto_path]
    /vol/tclsrcsol/tcl84/oratcl4.4/unix {/usr/tcl84/lib/tcl8.4 /usr/tcl84/lib}
    % package require Oratcl
    4.4
    % oralogon /

    %

    The casora shell code is some general code that all oracle shells, sqlplus invocations, etc. use to set the ORAHOME, etc. settings for a particular instance.

    It appears that oralogon is returning me a null string with no error indicator.

    Anyone know what I'm missing?

     
    • Larry W. Virden

      Larry W. Virden - 2006-05-22

      Just in case someone is interested, here's the build info.

      Platform: SPARC Solaris, with Sun's compiler.
      Configured with these options:
      \"'--prefix=/volws/lwv27/ldatae' '--enable-shared' '--enable-symbols' '--enable-stubs' '--enable-threads' '-with-oracle-directory=/vol/ora_client/product/9.2.0' 'CC=cc'\"

      and then I have to had modify the Makefile with this change:

      $ cat dif.Makefile
      112c112
      < SHLIB_LD_LIBS = ${LIBS} -L/vol/tclsrcsol/tcl84/tcl8.4.7/unix -ltclstub8.4g
      ---
      > SHLIB_LD_LIBS = ${LIBS} -L/vol/tclsrcsol/tcl84/tcl8.4.7/unix -ltclstub8.4g -L/vol/ora_client/product/9.2.0/lib -R/vol/ora_client/product/9.2.0/lib -lclntsh -lwtc9

       
    • Todd Helfter

      Todd Helfter - 2007-01-09

      um,

      How about setting the ORACLE_HOME environment variable before package require Oratcl.

      $ /usr/tcl84/bin/tclsh
      % info patchlevel
      % set env(ORACLE_HOME) /vol/ora_client/product/9.2.0
      % package require Oratcl

      -Todd

       
    • Larry W. Virden

      Larry W. Virden - 2007-01-11

      I'm setting that variable - doesn't help.

      I'm stuck at what is going on here.

       
    • Todd Helfter

      Todd Helfter - 2007-02-02

      Larry,

      The only thing I can think of would be to add $ORACLE_HOME/lib to your LD_LIBRARY_PATH environment variable.

      i.e.  (bash)
      export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$LD_LIBRARY_PATH

      -Todd

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks