Oratcl 4.5 on Windows 7

  • Keith Bradford

    Keith Bradford - 2011-12-09

    New windows 7 systems are not working with Oratcl … we have ActiveState TCL 8.5 and
    Oratcl 4.5.

    When we attempt to use the package we get …
    % package require Oratcl;
    couldn't load library "C:/Tcl/lib/Oratcl4.5/Oratcl45.dll": invalid argument

    We looked at Dependency Walker, and it shows no signs of missing dependencies.

    Anyone else have this problem or know how to work around?


  • Larry W. Virden

    Larry W. Virden - 2011-12-09

    Does the same version of activestate tcl and oratcl work for you on Vista or other older versions of Windows?
    I am wondering if perhaps there is something missing in your application. It's been a few years since I used oratcl, but I was thinking that with version 4.5, the application developer is responsible for setting some environment variables needed by Oratcl - perhaps that isn't being done?

  • Keith Bradford

    Keith Bradford - 2012-01-09

    Thanks for the response!

    Finally going back over this, and we have set :
    ORACLE_HOME (c:\oracle\ora10g)
    ORACLE_LIBRARY (c:\oracle\ora10g\lib)

    We also have the PATH set such that the oci.dll and Oratcl45.dll can be found (as verified by the "where" command):
    % exec  where oci.dll

    % exec where Oratcl45.dll

    still the same error … still looking!

  • Pradeep

    Pradeep - 2012-02-21

    Hi Keith,

    Were you able to resolve this problem? If yes, what is the solution?


  • Keith Bradford

    Keith Bradford - 2012-02-21

    No, were not able to resolve …  We had to move on and will probably have to come back to it someday.  We have workaround in place at the moment. 

    Thanks for asking.

  • Pradeep

    Pradeep - 2012-02-22

    Would it be possible to let me know the workaround?

    I have placed the Oratcl45 already in my ENOVIA's TCL lib folder and still it is not loading the file. I'm running out ideas on the same.

  • Keith Bradford

    Keith Bradford - 2012-03-05

    Sorry, Took a while to respond.  Our workaround was to move our jobs to a solaris or Red Hat server where the Oratcl library works fine.

    Its still not a answer, but its working for us this way.

    Good luck

  • Todd Helfter

    Todd Helfter - 2013-07-01

    There is a section on loading Oratcl on windows in the User's Guide found here on the site.
    Does this still not work on Windows 7? I'll admit I never tried it on Win7 before.

  • Yuvaraj

    Yuvaraj - 2014-08-26

    I am in need of using OraTcl 4.5 in Tcl 8.5 from Windows 7 / Windows Server 2008 R2 x64.

    If I use absolute path I get "invalid argument" error.
    % load D:/Matrix/lib/Oratcl45.dll
    couldn't load library "D:/Matrix/lib/Oratcl45.dll": invalid argument

    When I load from the directory I get different error.
    % load Oratcl45.dll
    couldn't load library "Oratcl45.dll": this library or a dependent library could not be found in library path

    Will OraTcl 4.5 work in windows? Also OraTcl 4.5 will work in 64 bit Tcl 8.5?

  • Todd Helfter

    Todd Helfter - 2014-09-02

    Oratcl will work in 64bit Tcl 8.5
    Oratcl will work in Windows 32b and 64b.
    However, the download of precompiled DLLs on this site was built for i686 platform, not true x64. Recommend compiling your own DLL from the source code or checking with ActiveState. ActiveTcl should include Oratcl as an option.

  • Todd Helfter

    Todd Helfter - 2014-09-02

    In regards to the post from 2012.
    This is not the proper setting for ORACLE_LIBRARY

    ORACLE_LIBRARY (c:\oracle\ora10g\lib)

    The proper value would be

    ORACLE_LIBRARY (c:\oracle\ora10g\BIN\oci.dll)

    This environment variable overrides the default behavior of looking in $ORACLE_HOME/lib



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks