OrangeHRM on Lighttpd

Apache
2010-02-22
2013-06-05
  • Mafaz Mazeen

    Mafaz Mazeen - 2010-02-22

    Is it advisable to run OrangeHRM on Lighttpd ?
    Please check this instance of it on Lighttpd http://86.1.105.47/orangehrm/login.php . The following error had to be corrected as in this jpgImage

    Fatal error: require() :

    Failed opening required '/var/www/html/25performance/symfony/lib/vendor/symfony/lib/plugins/sfDoctrinePlugin/lib/database/sfDoctrineDatabase.class.php' (include_path='.:/usr/share/php') in /var/www/orangehrm/symfony/lib/vendor/symfony/lib/autoload/sfAutoload.class.php on line 165

    The VMware Virtual machine used for the testing of 'OrangeHRM on Lighty' may be downloaded from this link http://www.marthomacentre.org.uk/ml/mod/forum/discuss.php?d=197

     
  • Mafaz Mazeen

    Mafaz Mazeen - 2010-02-23

    Hi,

    Use 2.5.0.2 instead 2.6 alpha. In 2.6 you have to manually change the database name on symfony/config/databases.yml. This has nothing to do with the platform.
    the new one has completely different core than the 2.5.0.2 and the modules are not configured yet. It was a alpha release for developers and QA people to check and should not be used for production under any circumstance.
    Only the PIM and ADMIN modules were changed to the new framework.

    Regards,
    Dulitha.

     
  • Mafaz Mazeen

    Mafaz Mazeen - 2010-02-23

    Thanks, Dulitha, for the quick reply to my question.
    This http://crm.et-home.co.uk/orangehrm/ is only a VM test site for exploring few FOSS applications on Lighttpd.
    Necessary changes were made to symfony/config/databases.yml and we look forward to the release of Version 2.6

    We will test 2.5.0.2 on the VM with a view to make it available to interested users ; e.g. http://fossnigeria.org/node/15

    George

    edit..

    2.5.0.2 installation went on smoothly & the instance is herehttp://crm.et-home.co.uk/orangehrm25

    Thanks
    Image

     
  • Arnold De Souza

    Arnold De Souza - 2010-10-25

    The database name on symfony/config/databases.yml. This has nothing to do with the platform.
    the new one has completely different core than the 2.5.0.2 and the modules are not configured yet. It was a alpha release for developers and QA people to check and should not be used for production under any circumstance.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks