Login.php - blank page after installation

  • Arnold De Souza

    Arnold De Souza - 2010-09-23

    Sorry about creating a new topic for this - but I have read all posts concerning the blank page issues and have not been able to correct it.

    The Problem
    After completely succesfully installing Xampp and OrangeHRM, the login.php is blank. IE7 even comments that it cannot read XML-input with the XSL provided.

    How did I install?
    With the one-click-installer provided by OrangeHRM. This did not work, so I installed Xampp latest version and a separate OrangeHRM 2.4.2 for Windows. Exactly same result. I am installing on Vista Business Edition. By the way - EVERYTHING WAS GREEN AND CORRECT UPON INSTALLATION CHECK.

    What did I try to solve the problem?
    - removed semicolons in php.ini, eventually all of them - just to be sure
    - checked extensions dir in php.ini
    - checked if php_mysql.dll existed in the extensions dir
    - checked if Apache and MySQL were correctly running as services
    - restarted Apache and MySQL several times, both from Xampp Control Panel and from Windows Service manager

    No luck so far. I really want to give OrangeHRM a chance, but this is just ridiculous and makes me want to throw it in the trash. I am not an IT-professional, but an experienced poweruser with sufficient knowledge of PHP and MySQL to be able to solve this. PLEASE HELP!

  • Arnold De Souza

    Arnold De Souza - 2010-09-23


    was this happened in IE7 only?
    if you set the envormental variable for mysql in windows, try to log into the mysql as root.

    mysql -u root -p

    the ideal reason for the blank page is, it is throwing an to the browser, you can't see it, it is because you are not set the php to show the error.
    usually it should set the development environment.

    open the php.ini file and change

    display_errors = Off

    display_errors = On

    Then restart the apache server.

    try to log in to the system.
    If you get the following error, the reason it mysql server is not up and running.


    NO database Connection found

    Technical Details
    Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) MySQL Error # :2002

    System Environment

    * OrangeHRM : 2.5
    * PHP : 5.2.6-3ubuntu4.2
    * MySQL Client : 5.0.75
    * Memory limit : 512M
    * Maximum session lifetime : 1440

  • Arnold De Souza

    Arnold De Souza - 2010-09-23

    Hi, i was facing the same problem. I followed the steps you have mentioned. Now it works fine. Thank you for your help.

  • Arnold De Souza

    Arnold De Souza - 2010-09-23

    I was looking for the same solutions, It helped me as well, thanks alot. :)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks