Hello!

I am having trouble getting OProfile to run on a arm linux system. I can compile OProfile without any trouble, but when I try to start it I get some error messages telling me that my kernel does not have the OProfile module.

I have tried recompiling my kernel, but since I am quite new to Linux, and extremely new when it comes to recompiling the kernel, this is giving me some trouble. I followed http://www.falkotimme.com/howtos/debian_kernel2.6_compile/ and successfully compiled both a kernel with the OProfile option set to included and one with it set as module. I can't seem to get mkinitrd to work though (or rather, can't find it) but after searching around a bit, I found that mkinitramfs is probably what I want to use. I successfully created a ramdisk and successfully started the system from the new kernel and ramdisk, but I still get the same error complaining about no kernel support. Have I missed something? When I do modprobe -l oprofile in my desktop computer, i find the oprofile module, but when I do the same on the arm system, it finds nothing. Since I have never recompiled the kernel, and don't really know how modules work, I am more or less at a loss about what to do next.

Grateful for any suggestions
//Leo