Hi all,
I installed the oprofile 0.5.4 (BTW, oprofile 0.6.0 and 0.6.1 could not be compiled at all, but after ignore the gui-related codes, I also managed to compile and build them) on a RH-7.2 486 compatible computer. However, when I tried to run "opcontrol --no-vmlinux --init", I got an error message like,
Cannot locate oprofile module
I then manually installed oprofile module with "insmod oprofile.o", but the error message persists. I ignored this message which I should not:-), and went ahead with collecting sampling data. But I got nothing under the /var/lib/oprofile/samples directory (not unexpected!).
I was told that with the RTC mode, oprofile should be able to used on unsupported architectures like accient 486 compatible, but it seems not easy to do it. I read the news arhive, someone mentioned that oprofile only supports SMP machines for RH 7.3 (or else 8.0, 9.0). How about the story with RH-7.2? 
Anybody out there have a better experience please point me to the right direction.
If you know some other tools, please share it with me. I have tried gprof, qprof, gcov, etc. My goal is to profile multithreaded applications on a RH-7.2 486 compatible uniprocessor machine.
Thanks and best,