Hi all:
I tried to run oprofile on SLES9/ppc64 and encounter some problems. The kernel version is 2.6.5-7.97-pseries64.

1.I used the latest oprofile: http://jaist.dl.sourceforge.net/sourceforge/oprofile/oprofile-0.8.1.tar.gz.
2.type ./configure --with-kernel-support
3.make(to compile successfully, you need to run "ln -s /usr/lib/libpopt.so.1 /usr/lib/libpopt.so") SLES9 don't do it by default.
4.make install
5.opcontrol --vmlinux=/boot/vmlinux-2.6.5-7.97-pseries64
This is the problem. It will report the following error:
cpu_type '(null)' is not valid
I am sure that it is when opcontrol executed "op_help --get-default-event" that reported this error.
op_help is an elf32 file installed by oprofile.
6.opcontrol --start
This will fail to start oprofiled too. It echoed the same error messages with 5.

I checked /dev/oprofile/ after step 5 and it showed the following:

cpu_type contained the following line:
Best Regards!

Chen Jian

LTC and pLinux Testing, China Software Development Lab, Beijing
TEL: 86-10-82782244-2838 FAX: 86-10-82782244-2887
E-mail: chenjian@cn.ibm.com
Address: 4/F, DeShi Building, 7th Street, Shangdi, Beijing 100085, PRC