I did start the sampling.. but it looks to me like a bug in centos 6.2 driver.. I wonder if anyone else stumbled upon this behavior.

On Tue, May 29, 2012 at 12:03 PM, Pedro Erencia <perencia@gmail.com> wrote:
I'm very new to OProfile, but i'd say that you must do opcontrol -s to start sampling, it's what opcontrol --start is supposed to do...

2012/5/28 Yossi Itigin <mister2g@gmail.com>

I am trying to use oprofile to sample a running process. The process takes 100% CPU, but still there are no samples from it in oprofile (just no-vmlinux, some daemons, and opreport itself get sampled)
However, if i start the process *after* starting oprofile (with opcontrol -s) - the process *does* get sampled.

I am using the default oprofile which comes with centos 6.2 - 0.9.6-21, kernel 2.6.32-220.el6.x86_64.
Tried to compile 0.9.7 from source and use it, but still get the same result.
oprofile log does not show any buffer overflows, by the way.


Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
oprofile-list mailing list