I have tried many various tricks before I created that post but nothing really helped so I decided to ask for some help.

I using SLES 9 sp4.
uname -a gives:
Linux server1 2.6.5-7.323-bigsmp #1 SMP Fri Aug 13 08:24:34 UTC 2010 i686

I have downloaded and installed oprofile package (from Novell site).
rpm -i oprofile-0.9.3-30.3.i586.rpm

Package was installed without complains.

Then I tried to use it. I executed:
server1:/root # opcontrol --init
server1:/root # opcontrol --no-vmlinux
server1:/root # opcontrol --start -V

The last commands produces the following output:

Using default event: CPU_CLK_UNHALTED:100000:0:1:1
executing oprofiled --session-dir=/var/lib/oprofile --separate-lib=0 --separate-kernel=0 --separate-thread=0 --separate-cpu=0 --events=CPU_CLK_UNHALTED:121:0:100000:0:1:1, --no-vmlinux --verbose=all
Events: CPU_CLK_UNHALTED:121:0:100000:0:1:1,
Using 2.6+ OProfile kernel interface.
Failed to open profile device: Device or resource busy
Couldn't start oprofiled.
Check the log file "/var/lib/oprofile/samples/oprofiled.log" and kernel syslog

oprofiled.log does not exists

When I check installed modules then lsmod shows oprofile

server1:/root # lsmod | grep oprofile
oprofile               62368  1

Mount shows:
root@server1:/root # mount | grep oprofile
nodev on /dev/oprofile type oprofilefs (rw)

I tried to unmount device, clear oprofile directories, re-installed package couple times nothing kelped.

I am using machine with 2 x CPU - Intel(R) Xeon(R) CPU           E5440  @ 2.83GHz

Can somebody help me to solve the problem ? I have very limited possibilities to install and re-compile the newest oprofile 9.7 and I have no guarantee that it can help so I did not do it.